10.7: std::vector type branches are empty in the output root file

Dear experts,
I’m trying to run the example B5 in the new version 10.7, but I have a problem with storing std::vector< G4double > in the output root tree: when the run is finished, the corresponding branches are empty. The other branches containing doubles are instead filled correctly.
I tried to compile the example B5 in version 10.6.2, and everything works as expected: std::vectors are stored correctly in the root file.
I am using Ubuntu18.04 with gcc 7.5.0. I compiled Geant4 in c++14 (but I tried also c++11 and the problem remains), and multithreading is enabled.
Do you know if there is something I am missing?
Thanks

Hello,
I can reproduce the problem. It seems to be a side effect of the new developments in analysis code in 10.7. I will investigate.
The problem happens when run in MT mode with ntuple merging activated, when merging is disabled the vector columns are filled correctly.

Best regards,

Dear Ivana,
thanks a lot for your answer! Hope to hear some news on this issue.
In the meantime, I will disable ntuple merging when running in MT.
Best regards
Riccardo