Activation of Synchrotron Radiation process

I am encountering strange problem after I created new release for Synchtrotron Radiation (SR) simulation using Geant4-10.1.2.
Is the UI command to activate SR still the same :
‘/physics_engine/tailor/SyncRadiation on’ ?
In my script I use it like this :

sync = 1

if sync :
simulation.param(‘UICommands’,[’/physics_engine/tailor/SyncRadiation on’,’/process/list’])

and I do not see SynRad in the list of processes. Even though I see in the list of simulation parameters that UI command is accepted.
With the former release with Geant4-9.6.2 I had used it the same way and it worked well.
Just to be sure that the command is still the same and maybe I have to look more carefully for
some other reason in my release.

Best regards

Hello Yuri,

please, try out

/physics_lists/em/SyncRadiation true


Hello Vladimir,

Thanks for quick answer.
I actually found this command and already tried it out and it disn’t work either.
No SynRad process in process list.


Coming back to Synchrotron Radiation after some break.

Let me reformulate my question:

I am using EM option 1 (EMV) . Shall I undertake some additional action/setting to activate SynRad or issuing the command :

/physics_lists/em/SyncRadiation true

is enough?
I am using this command without any additional action to activate SynRad and I do not see SynRad in the list of the processes.