Black screen with subtracted solid

Hi everyone,

Until now, I made a various simulations with an empty sphere on which I subtracted various cylinder and box at different angle to make holes into it. But when I tried to increase one (box) hole (which is subtracted multiple times) by 1cm, the compilation is going well however when I launch the OGL visualization I end with a black screen.

Any suggestions are welcome

What version of Geant4 are you using? Are there any warning messages?

I’m using the 10.07-p02 and I don’t have any messages. The visualization stay black and in my console I have the end of my Vis.mac file (I tried to reduce or change it but the problem is still here)

I’m sorry, but will you look back through your console messages. I would be very surprised if there is not some clue to the problem in there.

Please give as much detail as possible when filing a problem. What platform are you running on? What build configuration?

Nothing special appear on my console, I have the exact same console output as when I simulate smaller holes.
And like the only change between these 2 simulation is the size of the subtracted volume, I suspect it to be at fault here. But there are no errors that occur when compiling or launching.

Otherwise I’m running it on ubuntu 18.04.6 LTS and it was build whith cmake 3.10.2 …

Available UI session types: [ Qt, GAG, tcsh, csh ]

 Geant4 version Name: geant4-10-07-patch-02 [MT]   (11-June-2021)
  << in Multi-threaded mode >> 
                       Copyright : Geant4 Collaboration
                      References : NIM A 506 (2003), 250-303
                                 : IEEE-TNS 53 (2006), 270-278
                                 : NIM A 835 (2016), 186-225
                             WWW :

<<< Geant4 Physics List simulation engine: QGSP_BIC_HP

### G4HadronElasticPhysics: hElasticWEL_CHIPS_LEND
### G4HadronElasticPhysicsLEND: hElasticWEL_CHIPS_LEND
G4VModularPhysicsList::ReplacePhysics: hElasticWEL_CHIPS_HP with type : 5 is replaced with hElasticWEL_CHIPS_LEND
G4VModularPhysicsList::ReplacePhysics: hInelastic QGSP_BIC_HP with type : 6 is replaced with hInelastic ShieldingLEND
test 1 
Using Root
Visualization Manager instantiating with verbosity "warnings (3)"...
Visualization Manager initialising...
Registering graphics systems...

You have successfully registered the following graphics systems.
Registered graphics systems are:
  ASCIITree (ATree)
  G4HepRep (HepRepXML)
  G4HepRepFile (HepRepFile)
  RayTracer (RayTracer)
  gMocrenFile (gMocrenFile)
  OpenGLImmediateQt (OGLIQt, OGLI)
  OpenGLStoredQt (OGLSQt, OGL, OGLS)

Registering model factories...

You have successfully registered the following model factories.
Registered model factories:

Registered models:

Registered filter factories:

Registered filters:

You have successfully registered the following user vis actions.
Run Duration User Vis Actions: none
End of Event User Vis Actions: none
End of Run User Vis Actions: none

Some /vis commands (optionally) take a string to specify colour.
"/vis/list" to see available colours.
/run/verbose 1
/run/numberOfThreads 14
Construction géometrie...
distance detecteur  200: 565.301 cm
Géometrie complète
### HadronElasticPhysics::ConstructProcess: Elimit for for anti-neuclei 0.1 GeV for all hadrons Emax(GeV)= 100000
Dumping UsedTarget of LENDElastic for neutron
Requested Evaluation, Z , A -> Actual Evaluation, Z , A(0=Nat) 

**Initialization of the physic list**

G4WT11 > Using Root
G4WT11 > /control/saveHistory 
G4WT11 > /run/initialize 
G4WT11 > /run/physicsModified 
/control/execute vis.mac
/vis/open OGL
/vis/scene/add/trajectories smooth
/tracking/storeTrajectory 2
Attributes available for modeling and filtering with
  "/vis/modeling/trajectories/create/drawByAttribute" and
  "/vis/filtering/trajectories/create/attributeFilter" commands:
  Event ID (EventID): G4int
  Run ID (RunID): G4int
  Charge (Ch): unit: e+ (G4double)
  Track ID (ID): G4int
  Initial kinetic energy (IKE): G4BestUnit (G4double)
  Initial momentum magnitude (IMag): G4BestUnit (G4double)
  Initial momentum (IMom): G4BestUnit (G4ThreeVector)
  No. of points (NTP): G4int
  PDG Encoding (PDG): G4int
  Parent ID (PID): G4int
  Particle Name (PN): G4String
  Auxiliary Point Position (Aux): G4BestUnit (G4ThreeVector)
  Step Position (Pos): G4BestUnit (G4ThreeVector)
WARNING: Trajectory storing has been requested.  This action may be
  reversed with "/tracking/storeTrajectory 0".
/vis/modeling/trajectories/drawByParticleID-0/default/setDrawStepPts true
/vis/scene/notifyHandlers scene-0
/vis/modeling/trajectories/drawByParticleID-0/set neutron blue
/vis/scene/notifyHandlers scene-0
/vis/scene/endOfEventAction accumulate
WARNING: The vis manager will keep up to 100 events.
  This may use a lot of memory.
  It may be changed with, e.g., "/vis/scene/endOfEventAction accumulate 10".
/vis/viewer/set/autoRefresh true
/vis/verbose warnings
Visualization verbosity changed to warnings (3)
/gps/source/add 1
/gps/particle neutron
/gps/ene/type Mono
/gps/ene/mono 4. MeV
/gps/pos/type Point
/gps/pos/centre 0. 0. 0. cm
/gps/ang/type iso
/gps/ang/minphi 149 deg
/gps/ang/maxphi 157 deg
/gps/ang/mintheta 98 deg
/gps/ang/maxtheta 106 deg

this might be a stupid question: have you checked that you do not somehow subtract the complete volume and simply nothing is left over? to increase the “box hole by 1cm” could also mean that the whole box is 2cm by 2cm by 2cm larger, as dimensions in geant4 are typically half-lengths. depending on how large it was before, this could be quite significant :slight_smile:

otherwise you probably need to post some code…

1 Like

The mother value is a sphere whose diameter is about 1m , the part I want to remove is a box of 3*3cm (formerly 2 by 2 cm) with a length about twice the thickness of the sphere (which stay unchanged).
On the old simulation, the visualization doesn’t show any problems ans there is plenty of place for increasing the hole size.