Different result for low energy between G4 11.0.0 and G4 10.7.0

I simulated X-ray spectrum from a target sample by e- irradiation.
I use Penelope physics models.
But I got different spectra between G4 11.0.0 and G4 10.7.0. in the same source code.
I set min energy with 100 eV by

/cuts/setLowEdge 100 eV

and

G4ProductionCutsTable::GetProductionCutsTable()->SetEnergyRange(100 * eV, 1 * MeV);

G4 11.0.0 does not detect x-ray lower than 1 keV. G4 10.7 can detect this x-ray.
spec

EmParameter is

G4EmParameters* emParameters = G4EmParameters::Instance();
emParameters->SetAugerCascade(true);
emParameters->SetFluo(true);
emParameters->SetPixe(true);
emParameters->SetAuger(true);

I don’t know why these are different.

Please help.
Thanks.

Hello,

try to use

emParameters->SetDeexcitationIgnoreCut(true);

and/or

emParameters->SetLowestElectronEnergy(10*eV);

VI

Thanks civanch.

I tried to use

emParameters->SetDeexcitationIgnoreCut(true);

G4 11.0.0 detects Fluoro. lines but do not detect Bremss. less than 1 keV (See red line).
spec

emParameters->SetLowestElectronEnergy(10*eV);

does not change the result.

Do you have other solution or try?
Thanks a lot.

Hello,

Please, try

emParameters->SetLowestElectronEnergy(10*eV);

after "/run/initilise and Physics List is constructed, and before “/run/beamOn N”

VI

Hi,

I set

emParameters->SetLowestElectronEnergy(10*eV);

And after execute “/run/initialize” before “/run/beamOn N”.

In my case,

emParameters->SetLowestElectronEnergy(10*eV);

is described in the constructor of MyPhysicsList class.

Vladimir
Hi,

Where do I write

emParameters->SetLowestElectronEnergy(10*eV);

I write this in the construction of PhysicsList, normaly.
I try to write in the ConstructProcess in PhysicsList, but my results is without Bremss. below 1 keV.

1 Like

Hi

I try to use G4EMLOW7.13 on Geant4 11.0.0.
I can get the same result as Geant4 10.7.0.
Is there some problem or specification change in G4EMLOW8.0?
Can I use G4EMLOW7.13 on Geant4 11.0.0?

Thanks.