Error when running exampleB1

I am new to geant4 so please forgive me for my possible vague description.
After I reinstalled geant4, I tried to run exampleB1 to verify that geant4 was successfully installed. I “cmake” and “make” successfully, but after that when I enter “./exampleB1”, I got into trouble

-------- EEEE ------- G4Exception-START -------- EEEE -------
*** G4Exception : PART70001
      issued by : G4NuclideTable
ENSDFSTATE.dat is not found.
*** Fatal Exception *** core dump ***
 **** Track information is not available at this moment
 **** Step information is not available at this moment

-------- EEEE -------- G4Exception-END --------- EEEE -------

*** G4Exception: Aborting execution ***

### CAUGHT SIGNAL: 6 ### address: 0x3e80000081e,  signal =  SIGABRT, value =    6, description = abort program (formerly SIGIOT). 

[PID=2078, TID=-1][ 0/21]> /lib/x86_64-linux-gnu/ [0x7fd8cf61500b]
[PID=2078, TID=-1][ 1/21]> /lib/x86_64-linux-gnu/ [0x7fd8cf5f4859]
[PID=2078, TID=-1][ 2/21]> /home/zsh/Geant4/lib/ [0x7fd8cfaf0c87]
[PID=2078, TID=-1][ 3/21]> /home/zsh/Geant4/lib/ [0x7fd8d002ba86]
[PID=2078, TID=-1][ 4/21]> /home/zsh/Geant4/lib/ [0x7fd8d002c574]
[PID=2078, TID=-1][ 5/21]> /home/zsh/Geant4/lib/ [0x7fd8d002c60c]
[PID=2078, TID=-1][ 6/21]> /home/zsh/Geant4/lib/ [0x7fd8d0015589]
[PID=2078, TID=-1][ 7/21]> /home/zsh/Geant4/lib/ [0x7fd8d0017361]
[PID=2078, TID=-1][ 8/21]> /home/zsh/Geant4/lib/ [0x7fd8d0035f18]
[PID=2078, TID=-1][ 9/21]> /home/zsh/Geant4/lib/ [0x7fd8d00381e4]
[PID=2078, TID=-1][10/21]> /home/zsh/Geant4/lib/ [0x7fd8d073c3c5]
[PID=2078, TID=-1][11/21]> /home/zsh/Geant4/lib/ [0x7fd8d071e55e]
[PID=2078, TID=-1][12/21]> /home/zsh/Geant4/lib/ [0x7fd8d07f2082]
[PID=2078, TID=-1][13/21]> /home/zsh/Geant4/lib/ [0x7fd8d080d6f9]
[PID=2078, TID=-1][14/21]> /home/zsh/Geant4/lib/ [0x7fd8d07df905]
[PID=2078, TID=-1][15/21]> /home/zsh/Geant4/lib/ [0x7fd8d07e1b25]
[PID=2078, TID=-1][16/21]> /home/zsh/Geant4/lib/ [0x7fd8d088a4ad]
[PID=2078, TID=-1][17/21]> /home/zsh/Geant4/lib/ [0x7fd8d086ee96]
[PID=2078, TID=-1][18/21]> ./exampleB1(+0x7556) [0x555da509f556]
[PID=2078, TID=-1][19/21]> /lib/x86_64-linux-gnu/ [0x7fd8cf5f6083]
[PID=2078, TID=-1][20/21]> ./exampleB1(+0x80ce) [0x555da50a00ce]

How could I fix these error?Should I delete all the source and reinstall Geant4 again? :thinking:
Thank you very much!

Please see the Post Installation section of the Installation Guide.

Geant4 applications require environment variables to be set to point to physics data libraries, and there’s a shell script that needs to be sourced before running.

I think I have solved this problem.
The address of ENSDFSTATE.dat should be share/Geant4-11.0.3/data/G4ENSDFSTATE2.3 , and in my case, the address of ENSDFSTATE.dat was share/Geant4-11.0.3/data/G4ENSDFSTATE2.3/G4ENSDFSTATE2.3 . I put it in an extra directory G4ENSDFSTATE2.3. Now it worked.
Thank you very much!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.