G4MuMultipleScattering disable issue

Dear experts,

Hi, I’m a graduate student using GEANT4, and I’m trying to turn off the multiple scattering interaction for muons in FTFP_BERT model.

I tried two methods,

  1. Removing G4MuMultipleScattering class in G4EmStandardPhysics.cc
  • It works.
  1. Inserting ‘/process/inactivate msc’ in macro.
  • It doesn’t seem to work. Spreading of muon occurs. Coulomb scattering and the other interactions were turned off by method 1 above.

Is there any problem with the macro?

Thank you for reading.

Best regards,
Jaeyoung Jeong