GDML server down?

I am having trouble getting the GDML schema for validating GDML scripts. I define the URLs at the top of the GDML as:

and get the following error message:

G4GDML: VALIDATION ERROR! unable to open file ‘’ at line: 0
G4GDML: VALIDATION ERROR! fatal error during schema scan at line: 2

-------- EEEE ------- G4Exception-START -------- EEEE -------
*** G4Exception : InvalidRead
issued by : G4GDMLRead::Read()
ERROR - Empty document or unable to validate schema!
Check Internet connection is ON in case of schema
validation enabled and location defined as URL in
the GDML file - …/box-and-ccd.gdml - being imported!
Otherwise, verify GDML schema server is reachable!
*** Fatal Exception *** core dump ***
**** Track information is not available at this moment
**** Step information is not available at this moment

-------- EEEE -------- G4Exception-END --------- EEEE -------

I haven’t changed anything since the last time I worked on the simulation a few weeks ago, and things worked fine then. I changed the URL with the path to the gdml.xsd file in the Geant source code. This allows the simulation to run, but gives validation errors for every line in the GDML file. Any ideas how to fix this?

Which platform is this on, and which version/install options of Xerces-C are you building with? The server has migrated to SSL only recently, and we have seen some issues on Windows platforms - @gunter and @gcosmo can provide more details here.

1 Like

You can download the xsd file and replace the URL with your local path to the xsd file in the gdml file.

I am having same error, did you resolve this? If so how? I am using Ubuntu! The beginning of my file is as follows:

<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<gdml xmlns:xsi="" xsi:noNamespaceSchemaLocation="">

        <position name="ccfins_v0" unit="mm" x="14.039" y="-0.0275" z="-0.05"/>
        <position name="ccfins_v1" unit="mm" x="14.011" y="-0.0275" z="-0.05"/>
        <position name="ccfins_v2" unit="mm" x="14.011" y="14.0525" z="-0.05"/>
        <position name="ccfins_v3" unit="mm" x="14.011" y="-0.0275" z="-0.5"/>
        <position name="ccfins_v4" unit="mm" x="14.011" y="14.0525" z="-0.5"/>

Please get back to me as soon as possible.

Thanks very much!

the web server is not down, it currently redirects http requests to use https. The library to read GDML files, XercesC, depending on OS and build options may not be able to to read a file via https.
As workaround, download the schema file
using a web browser and save this file. Then, as written above by Zhiyhep, replace the url in your gdml file by a url pointing to your local file.

That worked!

Thanks very much!

I had the same error. I changed the link to:

and it worked for me. Is that link equivalent?