GEANT4 is not recognizing its own G4SimpleIntegration.hh

It’s me again Guys, two post in a row…
In some point of cmake building process, there is call for “G4SimpleIntegration.hh”. Suddenly the process broke due to some errors in definitions and signs. So far, i thought it can be solved by adding the missing pieces; However, the error comes from a file which is installed by default in geant4/include (I didn’t write it, so to have syntax is a super super weird thing).

Also i tried to google the source code go G4SimpleIntegration, i tried a couple of them, but all have similar errors…

here is an example output of what i got:

emph/app/ydeniz/GEANT4/geant4.10.6/geant4.10.06-install/include/Geant4/G4SimpleIntegration.hh:67:46: error: expected ‘)’ before ‘pFunction’
        explicit G4SimpleIntegration( function pFunction ) ;
/emph/app/ydeniz/GEANT4/geant4.10.6/geant4.10.06-install/include/Geant4/G4SimpleIntegration.hh:114:9: error: reference to ‘function’ is ambiguous
         function fFunction ;
/emph/app/ydeniz/EMPHATIC/DetectorSim/EMPHATICSim/ error: ‘G4TransportationManager’ has not been declared
   G4VPhysicalVolume* pWorld = G4TransportationManager::GetTransportationManager()->GetNavigatorForTracking()->GetWorldVolume();

I have not been able to solve this issue… Do you have any idea what could be the problem?

Thanks for your time guys!