Issue with binmake at LXPLUS

Dear experts,

I’m trying to compile a code in LXPLUS, but binmake.gmk is failing the touch step:

Creating shared library MYHOME/geant4_workdir/tmp/Linux-g++/CosmicRays/ …
touch: cannot touch ‘MYHOME/geant4_workdir/tmp/Linux-g++/CosmicRays/exe/obj.last’: No such file or directory
make: *** [MYHOME/geant4_workdir/tmp/Linux-g++/CosmicRays/exe/obj.last] Error 1

(MYHOME used above just to replace my actual home folder path.)

It seems binmake.gmk fails to create the folder “exe”, although it is clear in binmake.gmk at line 474 that this particular folder should be created if absent.

Besides, I see a file named obj.last at this path:

MYHOME/geant4_workdir/tmp/Linux-g++/CosmicRays/obj.last [w/o exe]

but no “exe” folder. I’m setting the following environment vars:

GEANT4 v10.7

source /cvmfs/

GCC v10

source /cvmfs/

Cheers, Gustavo

I’m not able to reproduce with the same setup and one of the basic examples, so I’d suspect an issue with the code’s own Makefile, or permissions/access on lxplus.

The binmake system is deprecated, so I’d recommend migrating the project’s build to CMake if possible.

Thanks Benjamin. I adapted the code to use cmake and it works now.