Macbook M1 issue with QT on Geant4

Hi, I just got an M1 Macbook pro. I have difficulty opening qt5 option on my Geant4 when make.
I followed the solution from “Trouble Building Geant4 with qt turned on in M1 mac - #2 by allison” :

and still got the same error complaining about qt

Please help me T T

1 Like

Could you post the full error message you are seeing please? We’d also recommend using the latest Geant4 version (11.0.2) on M1 Macs.

Hi bmorgan:
Thank you for fast your reply. : )
I am a new number for this Geant forum, I can only attach one figure:

I think it is also complaining about the Qt.
I remembered there are some functions in my Geant4 coding which cannot be used in the newest version of Geant4, so I am still using the Geant 4 version of 10.7.1…

The bottom error is:

I even tried to edit my zshrc file for the QT5 path:


After source, it still didn’t work
:joy:

You may need to delete and recreate the Geant4 build directory as CMake caches found packages. I’d guess as you noted it’s found the Conda Qt5, so it may have cached that and then ignored your update zsh settings.

Regarding screenshots, we much prefer if you are able to copy and paste the text directly inside fenced code blocks, e.g. typing

```console
$ echo "hello"
```

displays as:

$ echo "hello"

that makes it much easier to check and search the text.

Hi bmorgan:
Thank you so much! I think I fixed the problem after I followed your suggestion.
I am really appreciated your help!
:grinning: