Visualization closes immediately

visOutput.txt (41.3 KB)


I am trying to run the visualization for example B1 and the window closes as soon as it loads. I am ssh-ed into lxplus from my mac running OS Catalina 10.15.5. I am using GCC 8.2 and Geant4 10.05. I have attached the output from running ./exampleB1 init_vis.mac but I do not think there are any error messages. I have checked to make sure Xquartz is up-to-date on my local machine. Any advice on what is wrong is much apprecaited!


I believe it’s not at all mac-related. Please have a look at examples/basic/B1/README and the last section “C- HOW TO RUN”.
If you run the executable together with a macro name, it runs in a batch mode, so it initializes your simulation, executes the macro, and terminates.
In order to run an interactive mode please just use executable name: ./exampleB1. In case of example B1 it will automatically execute init_vis.mac in addition to starting an UI session. From there you would be able to run other commands, execute other macros, and it will “disappear” only when you close it.

Thank you! I am new to Geant4 obviously and don’t know where to find all the documentation. I am now getting the error:

Available UI session types: [ Qt, Xm, GAG, tcsh, csh ]
qt.qpa.plugin: Could not find the Qt platform plugin “xcb” in “”
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
Aborted (core dumped)

when I run ./exampleB1. Seems like Qt is not set up correctly. QTDIR is set, what else am I missing? I have tried remaking the example and that did not fix the issue.

Are you using G4 installation from cvmfs? You should source for the version you use, e.g. for 10.6 and gcc9:
source /cvmfs/
It’s a setup script that on top of sourcing sets a few additional variables (mostly for Qt, e.g. QT_XKB_CONFIG_ROOT).
Example instructions can be found here.

Thank you! This worked.

So did you get the visualization working now, if you just run ./exampleB1? That is you get the vis + the Idle prompt?