Can't get metastable levels of In during run

I have a beam of initial gammas which goes to Au(1 mm)+Ta(1 mm)+In(0.25 mm)+Cr(1 mm) target (0 - 80 MeV). Composition of In is In115 - 95.7 %, In113 - 4.3 %. And I want to get In111m [537], In112m [156], In113m [392], In114m [191], In115m [336] isomers. But I don’t see them! Why?
All what I see is In111, In112, In113, In114, In115, but I cannot get excited state of In during simulation. On the other hand I see that there are otheres metastable isomers for instance Pt196 [***]. Also I tryed to run rdecay01 example and if set 49 115 0 336.24, I wiil get the good agreement with experemental data (half life is 4.48 h).

And I want to get reactions as on the image

And when I run example Activation, I can get these metastable isomers, but only when I use heavy particles as projectile (deuteron for instance or neutrons with high energy).

But the main idea is that In foil should capture neutrons from reactions inside Au, Ta and Cr (work in reality), but in simulation there are no exited states of In…

So the problem is I cannot get excited state of In during run. Please help)

ShieldingLEND physics list. (Also tryed others, but there was nothing changed).

Thank you in advance!


you do not specify which Geant4 version you are using. In 10.4 and 10.5 my recommendation would to add radioactive decay physics on top of any physics list. For example:

QGSP_BIC* pl = new QGSP_BIC();

pl->AddPhysics(new G4RadioactiveDecayPhysics());

In 10.6 you need to check if radioctive decay physics is already enabled or not to avoid double definition. I also cannot recommend ShieldingLEND - cannot gurantee results.


I did what you told.

So now I use geant4.10.5-b version (before I used 4.10.6) and I set

QGSP_BIC* pl = new QGSP_BIC();
pl->RegisterPhysics(new G4RadioactiveDecayPhysics());

So I made very simple geometry: initial beam and In target, if I use neutrons 1 eV there are excited states of In for example:


But in case of using gamma with energy 14 MeV or 8 MeV or 20 MeV (doesn’t matter which energy), excited states are not appeared at all.Why? But there are should be these states (channels on the image). May be the reason of it is statistics (I ran more than 10000000 gamma of 14 MeV)… I will check that by supercomputer and let you know, but I think the result will be the same (will be happy if I am wrong)))

UPDATE: I made some calculations: I installed indium plate and used neutron and gamma beam with energies as on the image. All reactions with neutrons work fine (marked yellow color) but with gamma reactions doesn’t work at all (marked red color)

10 000 000 events each run. Maybe I missed some physic module about interaction gamma with matter…

Any advices please?))

Update_2: I also did simulation in Hadr03 example with using QGSP_BIC physic list and G4RadioactiveDecayPhysics. I simulated 100 000 000 gammas with 14 MeV energy into In plate 0.25 mm. And I didn’t see any exited states of In (attached file). I alredy think that thare is no option to simulate excited states from gamma… Am I rigth? Also I tryed to make the same think but with some othere materials, but get the same…
out_In.txt (2.4 KB)

I did the same exercice and came to the same conclusion ! PhotonNuclear process " ignore " metastable states.
And also ParticleHP package, so QGSP_BIC is ok for neutrons, but not QGSP_BIC_HP nor Shielding.
May I suggest you to open a bug report ?
Au196.mac.txt (220 Bytes)

Does the LEND database do any better? Or is the lack of isomer awareness in the PhotonNuclear process itself, rather than in the model/database?

For LEND, the data comes from . After unpacking, set the $G4LENDDATA envvar to point to the directory (full path). This is not done automatically by either the G4 installation or the and related setup scripts.

I also made simulation with these data, but got the same. There are no production of isomers from photonuclear process. Moreover, this liblary doesn’t work with low energy neutrons. Fo example I run 100 000 000 1 eV neutrons into In plate and didn’t see any excited states. But with QGSP_BIC there are isomers in case of using neutrons.

I opened a bug report!

Hey Aleksei,

I am having a similar problem as you are in this post and was wondering if you ever got the problem figured out? My email is if that is easier!

Hi. Sent you an email. Also please read this topic Cross-sections (2020 Planned Features).