Any issue with drawVolume command

Hello fellows,

Actually, I am installed my Geant4 with QT and OPENGL enabled. Now after all the installation I checked the example B1 which is running fine and smooth. But then I try to run the similar exampleB5 but I am getting hang/lack issue when I am executing the program after built. Then, I try to made a simple program which is just a simple G4box and I just try to visualize my box with th “/vis/drawVolume” command. But after using this command, my system got hanged and after 4-5 second program execute and there is not box ot anything, but If i remove this drawVolume command, then everything is working perfectly and smoothly.

Can you please tell me what the issue with my system or program or installation?


Hmm. Something strange about your build. Can you tell us exactly where it hangs/crashes with a debugger? Please attach a copy of the exact output up to the point of crash. Please let us know the Operating System, Geant4 version and Qt version.

It hangs for couple of a second then it opens a blank OGLSX window. I also tried GDB runner but there’s no error and when it tries to open the graphic window it hangs similar like the executable run program.

By the way, I am using UBUNTU 22.04.2 version with kernal: 5.19.0-38-generic, and my geant4 is latest one GEANT4v-11.1.1, and I installed Qt5 version for visulization.

Actually, I also thought that there could be a issue with Qt but then I again built it without Qt and default openGL_X111 =ON. But, I am again getting the same error and hang when I am trying to give this drawVolume command.

I am also wondering that If there is an issue with my buld then how tis exmpleB1 is running so smoothly without any lag?

here is my main and output file: (3.5 KB)

sim.txt (5.2 KB)

I am attaching this scrrenshot of the output as well:

Also, here is my build options if you want to know:

I tried first with Install_Qt=ON but I thought there’s some issue with QT then I again built it with QT=OFF and default OPENGL_X11 = ON

I am attaching my system details for your reference as well. Please take your time:
have a dedicated NVIDIA graphic card and integrated amd card. I am listing details of both by using “lspci | grep VGA” command:

VGA compatible controller: NVIDIA Corporation TU117M [GeForce GTX 1650 Mobile / Max-Q] (rev a1)
VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Renoir (rev c6)

Please suggest me something how did you solve this issue. I will be great help.
I am also sharing my system details:
OS: Ubuntu 22.04.2 LTS
Geant4: 11.1.1
Processor: AMD® Ryzen 7 4800hs with radeon graphics × 16
Graphics: AMD Renoir and NVIDIA (I also mentioned it above).
Qt version: Qt 5.15.3
[linux version 5.19.0-38-generic]

Hi Anil

You seem to have font issues. Check that X11 is correctly installed.

Also, try /vis/open TSG. I think TSG uses different fonts.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.