B1 running error in runbeam

My laptop config :
intel® Core™ i3-7100U Processor (3M Cache, 2.40 GHz )
I’ve run the B1 example Beam on 10^6 and got doserate. When i run the particles 10^7, my laptop got hang. I need Appox 10^11 to 10^13 particles to get result.
What should i do to get solution?

/tracking/storeTrajectory 0
/run/printProgress 1000000
/run/beamOn 1000000000
wait for results…

measure the time for smaller numbers (say, 1e6 particles), before launching the “big run” to know what to expect… if 1e6 particles takes 1 second, 1e11 particles takes more than 1 day.

keep in mind that you might have to stitch different runs to get your desired number of 1e11 particles, since the event number is an int-value (maximum is around 2e9).

you should also consider multi-threading, you will find examples if you look for it :slight_smile:

Why do you need so many particles? Can you not run, say 10^6, and scale the result to your experiment?

I know, int-value couldn’t exceed 10^10. I tried to check how large the value.
Can you please, help me to consider multi-threading?
I couldn’t enable it. :slightly_smiling_face:

Did you build your Geant4 installation with multithreading enabled? Building and Installing from Source — Geant4 Installation Guide 10.7 documentation

Did you specify the multithreaded run manager in your main()?

I installed Geant4 from miniconda and run the exampleB1 from conda environment.


After digging some time,

Yes, It’s built with MULTITHREADED=ON support for conda install. To reduce run time you have to specify multithreaded run manager in your main() for event-level parallelism via multi-threading.