Black screen in Qt for example B1

Hi Geant4 experts!
I have a problem with visualization in Qt5 GUI. I have installed Geant4-v11.0.3 on my WSL2 (Win10) using CMake 3.16.3. I used GEANT4_USE_QT=ON (Qt version 5.12.8)
and also provided the appropriate CMAKE_PATH_PREFIX for finding the Qt5 directories for:
Qt5Core_DIR, Qt5Gui_DIR, Qt5OpenGL_DIR, Qt5PrintSupport_DIR , Qt5Widgets_DIR .
The installation was successful, as well as the building of B1.
When I run the exampleB1.exe the Qt windows open as expected but instead of the visualization, I see only a black screen. I do not get any errors in the console. Apart from that, the UI works well. I can enter commands and also open a new viewer (also black).
I found this forum post with a similar problem on Windows:
But here Alex got an error message. So I am not sure if this is a similar problem. I could also not try his solution, since it was to change some Code, that looks different for my setup. Also I tried using not Qt but only OpenGL. Here I initially see the 3D visualization but as soon as I move the window it gets black. My laptop uses a Intel HD Graphics 620 which uses OpenGL version 4.4.
Does someone uses WSL and has encountered this issue before? :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.