Can not login with email

Hello, I recently had to create this account since I can no longer access my old one.

A little over a year ago I created my first account with my email and, while my account still exists (@Gabriel) I can no longer access it. When I click the “login” button there is still an option to login with email, however, when I press that button an error message immediately appears which says Please enter your email or username however there is no region for me to enter this information. I have attempted to login on both Safari 13.1.1 and Chrome 83.0.

While access to that specific account is not essential for me, it is irritating that I no longer have access to the account I created with my professional email.

Is there anyway for me to regain access to my old account?

Your account appears to be valid and associated to this email address: Is that correct?
Have you tried resetting your browser and clearing its cache?

Yes that is my email and account.

I have tried with multiple browsers, I installed chrome for the first time on suspicion that it was a Safari issue. I’ve also made sure to disable content blockers on both browsers all to no avail.

On the login window I can click on the GitHub link and the CERN SSO Link both of which open a page where I can input login credentials. It is only the email button which seems to not work.

I’ve attached a screenshot which shows my error message, again there is no actually space to enter an email when I click on the email button.

Could you try again to see if the problem persists?

As of Aug 8, 2020 problem still persists