Cannot find source file with IAEAphspReader

Dear all,
I got this error when using the IAEAphsp library to read TrueBeam STX phsp file. I don’t know what is the cause. Can someone help me?
image

I have tried reading some other IAEAphsp files like Varian_Clinac_600C_6MV_10x10 but I don’t see this error.

As this is a library external to Geant4, it’s best to contact the authors of the package as they’ll be in a better position to help you.

Thank you. I will try this one !!!

Dear @bmorgan,
I tried rebuilding the source code on a Linux system but it seems to give me a different error

To resolve a segmentation violation, you’ll need to run the program through a debugger like gdb which can pinpoint the line(s) causing the problem.

Thank you so much. I will find the ways to fix it.

Hi, are you using the official phase space file on the website or are you using your own generated phase space file?

Dear @Jodie_Comer,
Thank you for insterested in my post.
I used IAEAphsp on IAEA websites. I think there are some problems with TrueBeam files.
If I used my files that generated following to IAEA Writer routine. There are no mistakes occurred.

If you are using your own phase space file, have you used the GNUmakefile as described in the manual, in addition to including the following files.

  • iaea_config.h
  • iaea_header.h and iaea_header.cc
  • iaea_phsp.h and iaea_phsp.cc
  • iaea_record.h and iaea_record.cc
  • utilities.h and utilities.cc

Dear @Jodie_Comer, I want to discuss this with you. Can you give me your email?

Sure, but I actually don’t know much about this phase space file. All I know is what I read in the manual, if you still want to communicate with me this is my email
2135983039@qq.cm