Can't open HepRep.jar browser

I use Ubuntu 22.04 version. After downloading HepRep.jar file from here HepRApp Users Home Page try to open it via java -jar command. The java version is 1.8.0_352. But browser is not running. In terminal there are shown that:

Exception occurred in main() of HepRApp: java.lang.UnsupportedOperationException
at java.lang.Runtime.runFinalizersOnExit(
at java.lang.System.runFinalizersOnExit(
at heprapp.application.Main.main(

What is the problem ?

Hi Sergey

I’m afraid I can’t help specifically but I do know that HepRApp is picky about Java versions. Have you tried searching the Forum for HepRApp or Java?

If you still have no luck, let us know and I’ll forward this to an expert. It’s worth persisting to get HepRApp to work.


I couldn’t found solution of the problem. Please forward it to an expert.

Hi Sergey

I’m afraid I’ve not been able to get any help on this topic. For the moment, all I can say is that HepRApp does not seem to be available with recent versions of Java.

According the HepRApp web site, it was last updated:

29 March 2016 - Version 3.15.4
Updated for newer Java versions. Now works for Java 1.7 and 1.8. Thanks to Brian Smith of Kromek Group plc

so all I can recommend is that you install that version of Java, if possible.

An alternative might be the VRLM2FILE driver. Almost any web browser can display the files it produces, but, of course, the very nice Geant4-specific features of HepRApp are absent.

With apologies

Hi Sergey,

I ran into same issue recently and I was using Ubuntu 22.04 version + java 1.8.0_352. After tring all the java versions I could find, I succeeded run HepRApp with Java 1.7.0_80. See screenshot below

Not eactly sure what is the cause. I was able to run it with java 1.8.0_352 for more than 2 years and suddenly this configuration doesn’t work anymore.

Just sharing my solution. And maybe somebody knows java more coud explain this.


Dear Jiancheng

Thankyou for this tip. Very, very helpful.