Core dump while creating World box within specific size


I am new to Geant4 and encountered a problem while creating a world box within specific size.
What i did was copying the basic example B1 from the main folder and pasting to another folder, deleting all the elements of the Construct() function inside, and trying to create a new model.

Below is the world box i was trying to create.

G4Box * world  	 = new G4Box("world", 15* um, 15* um, 2000 * um );
G4Material* Air    = nist->FindOrBuildMaterial("G4_AIR");
G4LogicalVolume* lworld   = new G4LogicalVolume(world, Air, "world");
G4VPhysicalVolume* pworld = new G4PVPlacement(0, G4ThreeVector(), lworld,
                                              "world", 0, false, 0, false);
return pworld;

The build process ended successfully. The “make” process inside the build folder was also successful, but when i tried to execute the ./exampleB1 , I always got a “core dump”.
This error does not occur when the unit is changed to e.g., 15 cm, or if the size is smaller e.g., 15 nm.
I tried to avoid the error by using 15 * 1000 * nm, but it also didn’t work.

I didn’t get any error message at all and have been trying to solve the problem for couple hours, yet can’t think of any solution.
Is there any configuration elsewhere that i perhaps have to set, to make the size works?

I would really appreciate for tips and help for this matter

Thank you,

p.s.: am using Geant4 10.5

did you change anything in the examples/basic/B1/src/ · geant4-10.5-release · geant4 / geant4 · GitLab?

No, i did not change anything else beside the Construct() in B1DetectorConstructor.
I just took it raw from the basic example folder, and modified the Construct().

perhaps you could try to make some adjustments there, such that the particles are all created at the origin?

As I understand, particle positions are randomly sampled depending on some envelope. This way you could eliminate this, and see if that helps.
As I further understand, the random engine is deterministically seeded, hence, the core dump is also reproduced reliably.

That’s a nice tips!
I will try to do it first.

Thank you


I have tried to set the particle gun to be placed on the 0,0,0

and set the particle to move in Z direction

to ensure that the particle is shot within the “World” range.

I’ve also tried to look for another files within src folders, hoping to find some clue where i might screwed up, or perhaps found some missing configuration.
But i didn’t find any configuration, that stated that i cant use that specific world size.

Does anyone perhaps have the same problem as mine?

Any further help or response would be much appreciated

Thank you,