Energy deposition in He3

Hi,

I am propagating cosmic rays (from CRY) into some surrounding material measuring the energy deposited in He3.
For very low energies, I get a spike at exactly 23.42 eV usually deposited by gamma in a Compton scattering process (or in transportation).

In some cases is a daughter gamma, from an electron parent, carrying the whole 23.42 eV of kinetic energy.

I see a similar peak if shooting as primaries gammas, electrons or some other isotopes.

Is there any particular physics phenomenon I am missing at that particular energy? apparently Helium first ionization is 24.5 eV which is not miles away.

Thanks,

Paolo

2 Likes

Hi Paolo,

I am a bit puzzled by this. In principle it could be K_alpha from He? (Although this fluorescence should be largely below threshold). Which physics list and which settings/cut are you using? Can you determine which kind of particle carries 23.42 eV and which is the generator process?

Ciao,
Luciano

1 Like

Ciao Luciano,

thanks for the answer.
Yes is slightly below the ionization threshold.
It is usually a gamma and the GetPreStepPoint()->GetProcessDefinedStep()->GetProcessName() is most of the time a Compton; the physics lists are:

  RegisterPhysics(new G4EmLivermorePhysics());                                                                                                  
  RegisterPhysics(new G4DecayPhysics());
  RegisterPhysics(new G4RadioactiveDecayPhysics());

and I am not applying any cut.

Indeed, I was reading in papers about the He X-ray lines and there are ~23, ~24 eV contributions.

Hi,

in principle the G4LivemoreComptonModel will try to produce fluorescence, following the electron vacancy which is left in the target atom after the Compton Scattering. However, I am not sure of how the AtomicDeexcitationManager handles the He case… Just to be sure, could you please disable the atomic deexcitation via
/process/em/fluo false
and/or avoid the production of sub-threshold secondaries:
/process/em/deexcitationIgnoreCut false

By the way, which Geant4 version are you using?

Ciao,
Luciano

Hi,

Will make the check you suggested. I am currently using 10.7,

cheers,
Paolo

what’s the way of doing this in c++ without using a mac file?
Thanks.

this should do

#include "G4EmParameters.hh"
[...]
  G4EmParameters::Instance()->SetFluo(false);
  G4EmParameters::Instance()->SetDeexcitationIgnoreCut(false);
2 Likes

Do I need to write my own physics list builder, wrapping G4EmLivermorePhysics to turn off those 2 parameters? Or there is another way for doing that? Right now I have a physics.cc like this

#include "physics.hh"

MyPhysicsList::MyPhysicsList()
{

  RegisterPhysics(new G4EmLivermorePhysics()); 
  RegisterPhysics(new G4DecayPhysics());
  RegisterPhysics(new G4RadioactiveDecayPhysics());

}

MyPhysicsList::~MyPhysicsList() {}

Thanks.

Yep

Ciao Paolo,

you don’t need a wrapper, you can change the settings directly from the C++ code, using the G4EmParameters, just the way you wrote below. You can even do that in the main(), after you feed the physics list to the RunManager.

Thanks, I was doing it after the runManager. Now:

  G4EmParameters::Instance()->SetFluo(false);
  G4EmParameters::Instance()->SetDeexcitationIgnoreCut(false);

  // G4 Run Manager                                                                                                                                                         
  G4RunManager *runManager = new G4RunManager;
  runManager->SetUserInitialization(new MyDetectorConstruction());  // detector geometry                                                                                    
  runManager->SetUserInitialization(new MyPhysicsList());           // physics process                                                                                      
  runManager->SetUserInitialization(new MyActionInitialization());  // primary particle

  G4EmParameters::Instance()->Dump();
=======================================================================
======                 Atomic Deexcitation Parameters          ========
=======================================================================
Fluorescence enabled                               1
Fluorescence Bearden data files enabled            0
Auger electron cascade enabled                     0
PIXE atomic de-excitation enabled                  0
De-excitation module ignores cuts                  0
Type of PIXE cross section for hadrons             Empirical
Type of PIXE cross section for e+-                 Livermore
=======================================================================

should it be enabled 1?
I still see ~24eV events though.

My mistake, if SetFluo(false) I understand that the Atomic Deexcitation Parameters table is not shown at all.

But still I see the very same number of 2.342e-05 MeV events as before.

Ok, this means that the energy deposit is not due to real secondary tracks, but to the Compton model itself. Could you please check if the structure disappears by using a different EM constructor (e.g. G4EmStandardPhysics_opt3 or G4EmPenelopePhysics) ?

Also, what’s the primary gamma energy we are talking about?

It could be an artifact from the model…

Thanks! Have been checking G4EmPenelopePhysics and

  • 1 MeV gamma beam: I get 24.59 eV energy deposition from gammas via Compton scattering
  • 1 MeV electron beam: 23.41 eV (and few 24.59 eV) energy deposition from gammas via Compton scattering
  • Bi-210: 23.41 eV and 24.59 eV energy deposition from gammas via Compton.

Is the Compton physics process common to physics lists?

Haven’t figured out yet how to load the G4EmStandardPhysics_opt3…

And this is confirmed with the Fluorescence flag set to false ?

Yes

  G4RunManager *runManager = new G4RunManager;
  runManager->SetUserInitialization(new MyDetectorConstruction());  // detector geometry                                                                                    
  runManager->SetUserInitialization(new MyPhysicsList());           // physics process                                                                                      
  runManager->SetUserInitialization(new MyActionInitialization());  // primary particle                                                                                     

  G4EmParameters::Instance()->SetFluo(false);
  G4EmParameters::Instance()->SetDeexcitationIgnoreCut(false);
  G4EmParameters::Instance()->Dump();                                                                                                                                     

  runManager->Initialize();

(I assume it works, because if I turn it true I can see the Atomic Deexcitation Parameters table being shown.

Should we think that the Compton process is causing this?
I have tried with 10.7.p04a but I get the very same results.