Error for geant4 installation

Hi Dear geant4 user !
I’m trying to install geant4 on ubuntu 16.04, but i have some problem to finish my installation. Someone

can help me to fix it ?

This is the c-make error.
can you please tell me which c-make version you have downloaded?
and also, do you know your device has 7 number of processers? because i have doubt on your previous command “make -j7” if you don’t know this, please check first by giving command “nproc”.

I don’t think it’s anything to do with the build - the error is saying that you don’t have the suitable UNIX permissions on directories under /home/cepamoq. Check the file/directory permissions there, and the user you’re running as.

If /home/cepamoq is your day-to-day home directory, I would not recommend building anything directly here. It will cause problems later on.

Thank for your reply. I have cmake 3.5.1, and my device processor number is 3. I tried using the great device processor number, but I got the same error.

Here is the directory where I build it. Capture du 2021-03-03 16-16-46

What do ls -larth /home/cepamoq and ls -larth in the directory where you are trying to build Geant4 print? What does pwd print?

I’ve got a feeling it’s something to do with running CMake under sudo. There’s never a need to do this as sudo is only needed if the install is going to go into a system level directory.

I fixed the error. The problem is that, I forgot to use sudo before make, when I ty to build.
Thank for your help.

You should not be having to use sudo at all, unless you are trying to install Geant4 into a system directory (which is generally not recommended).

I agree with the predecessor. Using SUDO is highly inadvisable to build Geant4. Later I had problems with such an installation and strange errors. Should be compileable without sudo. Only installation (if elsewhere) may require sudo.