Error in terminal:G4BinaryLightIonReaction.cc: Cannot correct 4-momentum of cascade particles

Hi experts.
**I tried to simulate high hadron beams for high energies in the water phantom. **
**I am faced with this error in the terminal. I changed physiclist differently. I used hadronic examples physiclists in geant4 but it didn’t work. **
please help me.
I used Geant4 version 11.01

G4WT0 > G4BinaryLightIonReaction.cc: Cannot correct 4-momentum of cascade particles
G4WT0 >
-------- EEEE ------- G4Exception-START -------- EEEE -------
*** G4Exception : had006
issued by : G4HadronicProcess::PostStepDoIt
In /home/mohaddese/Geant4/source/source/processes/hadronic/models/binary_cascade/src/G4BinaryLightIonReaction.cc, line 220:
===> G4BinaryCasacde::ApplyCollision()
Call for Binary Light Ion Cascade
Target element H Z= 1 A= 1
Unrecoverable error in the method ApplyYourself of tInelastic
TrackID= 1 ParentID= 0 triton
Ekin(GeV)= 1.14029; direction= (0.0120396,-0.0130088,0.999843)
Position(mm)= (2.5781,8.69101,202.828); material G4_WATER
PhysicalVolume
ApplyYourself failed

*** Fatal Exception *** core dump ***
G4WT0 > G4Track (0x7ff1529b5460) - track ID = 1, parent ID = 0
G4WT0 > Particle type : triton - creator process : not available
G4WT0 > Kinetic energy : 1.14029 GeV - Momentum direction : (0.0120396,-0.0130088,0.999843)
G4WT0 > Step length : 822.879 um - total energy deposit : 242.691 keV
G4WT0 > Pre-step point : (2.56818,8.70175,202.005) - Physical volume : phantom (G4_WATER)
G4WT0 > - defined by : hIoni - step status : 4
G4WT0 > Post-step point : (2.5781,8.69101,202.828) - Physical volume : phantom (G4_WATER)
G4WT0 > - defined by : tInelastic - step status : 4
G4WT0 > *** Note: Step information might not be properly updated.
G4WT0 >
-------- EEEE -------- G4Exception-END --------- EEEE -------

G4WT0 >
G4WT0 > *** G4Exception: Aborting execution ***

CAUGHT SIGNAL: 6 ### address: 0x3ec000028cd, signal = SIGABRT, value = 6, description = abort program (formerly SIGIOT).

Backtrace:
[PID=10445, TID=0][ 0/23]> /usr/lib/x86_64-linux-gnu/libc.so.6(gsignal+0xcb) [0x7ff15c38700b]
[PID=10445, TID=0][ 1/23]> /usr/lib/x86_64-linux-gnu/libc.so.6(abort+0x12b) [0x7ff15c366859]
[PID=10445, TID=0][ 2/23]> /home/mohaddese/Geant4/Install/lib/libG4global.so(Z11G4ExceptionPKcS0_19G4ExceptionSeverityS0+0x1117) [0x7ff15c850e87]
[PID=10445, TID=0][ 3/23]> /home/mohaddese/Geant4/Install/lib/libG4global.so(_Z11G4ExceptionPKcS0_19G4ExceptionSeverityRNSt7__cxx1119basic_ostringstreamIcSt11char_traitsIcESaIcEEE+0xa5) [0x7ff15c851025]
[PID=10445, TID=0][ 4/23]> /home/mohaddese/Geant4/Install/lib/libG4processes.so(+0x40c930) [0x7ff15aa31930]
[PID=10445, TID=0][ 5/23]> /home/mohaddese/Geant4/Install/lib/libG4tracking.so(_ZN17G4SteppingManager11InvokePSDIPEm+0x55) [0x7ff15d581b15]
[PID=10445, TID=0][ 6/23]> /home/mohaddese/Geant4/Install/lib/libG4tracking.so(_ZN17G4SteppingManager23InvokePostStepDoItProcsEv+0x8b) [0x7ff15d5822db]
[PID=10445, TID=0][ 7/23]> /home/mohaddese/Geant4/Install/lib/libG4tracking.so(_ZN17G4SteppingManager8SteppingEv+0x46c) [0x7ff15d57e81c]
[PID=10445, TID=0][ 8/23]> /home/mohaddese/Geant4/Install/lib/libG4tracking.so(_ZN17G4TrackingManager15ProcessOneTrackEP7G4Track+0x118) [0x7ff15d594488]
[PID=10445, TID=0][ 9/23]> /home/mohaddese/Geant4/Install/lib/libG4event.so(_ZN14G4EventManager12DoProcessingEP7G4Event+0x893) [0x7ff15d5d5303]
[PID=10445, TID=0][10/23]> /home/mohaddese/Geant4/Install/lib/libG4tasking.so(_ZN22G4WorkerTaskRunManager15ProcessOneEventEi+0x3c) [0x7ff15d74ec1c]
[PID=10445, TID=0][11/23]> /home/mohaddese/Geant4/Install/lib/libG4tasking.so(_ZN22G4WorkerTaskRunManager11DoEventLoopEiPKci+0x17e) [0x7ff15d74eb5e]
[PID=10445, TID=0][12/23]> /home/mohaddese/Geant4/Install/lib/libG4tasking.so(_ZN22G4WorkerTaskRunManager6DoWorkEv+0x15d) [0x7ff15d74eead]
[PID=10445, TID=0][13/23]> /home/mohaddese/Geant4/Install/lib/libG4tasking.so(_ZN22G4TaskRunManagerKernel17ExecuteWorkerTaskEv+0x6a) [0x7ff15d74bd3a]
[PID=10445, TID=0][14/23]> /home/mohaddese/Geant4/Install/lib/libG4tasking.so(+0x3a2d6) [0x7ff15d73b2d6]
[PID=10445, TID=0][15/23]> /home/mohaddese/Geant4/Install/lib/libG4tasking.so(_ZNSt13__future_base13_State_baseV29_M_do_setEPSt8functionIFSt10unique_ptrINS_12_Result_baseENS3_8_DeleterEEvEEPb+0x2d) [0x7ff15d74338d]
[PID=10445, TID=0][16/23]> /usr/lib/x86_64-linux-gnu/libpthread.so.0(+0x114df) [0x7ff1593244df]
[PID=10445, TID=0][17/23]> /home/mohaddese/Geant4/Install/lib/libG4tasking.so(_ZN3PTL4TaskIvJEEclEv+0x12c) [0x7ff15d74350c]
[PID=10445, TID=0][18/23]> /home/mohaddese/Geant4/Install/lib/libG4ptl.so.0(_ZN3PTL10ThreadPool14execute_threadEPNS_14VUserTaskQueueE+0x351) [0x7ff15c7486d1]
[PID=10445, TID=0][19/23]> /home/mohaddese/Geant4/Install/lib/libG4ptl.so.0(_ZN3PTL10ThreadPool12start_threadEPS0_PSt6vectorISt10shared_ptrINS_10ThreadDataEESaIS5_EEl+0x1a3) [0x7ff15c748e33]
[PID=10445, TID=0][20/23]> /usr/lib/x86_64-linux-gnu/libstdc++.so.6(+0xd6df4) [0x7ff15c627df4]
[PID=10445, TID=0][21/23]> /usr/lib/x86_64-linux-gnu/libpthread.so.0(+0x8609) [0x7ff15931b609]
[PID=10445, TID=0][22/23]> /usr/lib/x86_64-linux-gnu/libc.so.6(clone+0x43) [0x7ff15c463353]

: Aborted (Signal sent by tkill() 10445 1004)
Aborted (core dumped)

Can you please try to run an hadronic test of Geant4, without changing anything?
even the advanced example hadrontherapy would be fine.

Thank you
Susanna

1 Like

thanks. I did it, run had03 example even with higher energies and 10^8 particles. it is ok.

Generally, when I run my program with high-energy tritium or deuteron beams with particle number (10^8), I see this error. but if I use less incident particle numbers like 10^7, it works fine.

Not sure. It is strange. if the problem is visible with a Geant4 example, my suggestion is to submit a report to bugzilla,

cheers
Susanna

1 Like

Hello,
Can you please submit a bug report to keep track of this bug? The code hits a rare condition causing an exception, or crash; its a real bug, curiously seen independently by two users. I am trying to understand the cause, and for now only have a workaround to avoid a crash.
Gunter

1 Like

Thanks. I tried to sign up to report the bug. Unfortunately, they need preauthorization, so I can’t report it.