Error when installation time doing make -jN command

Hello Experts,
Can you please tell me that why this is coming like this . when one of my friends is installing Geant4 . i am not really getting it.
why it is saying protocol error ?
Thanks in advance!

„make“ cannot download the dataset files. you would need to download them manually as needed, and set

Strange, I just tried and this is working for me

$ cmake -DGEANT4_INSTALL_DATA=ON ../geant4.10.07.p02
$ make
[  0%] Creating directories for 'G4ENSDFSTATE'
[  0%] Performing download step (download, verify and extract) for 'G4ENSDFSTATE'
-- Downloading...
   timeout='1500 seconds'
-- Using src=''
-- [download 100% complete]
-- [download 5% complete]
-- [download 100% complete]
-- verifying file...
-- Downloading... done
  • Could your friends internet have dropped out for a moment?
  • There is an MD5 hash error related to an existing file. Not sure why this would cause an issue, but try removing everything from /home/caroline/Documents/Geant4/genat4.10.07.p02-build/Externals/ and re-running the make command.

the error message above states: Protocol "https" not supported or disabled in libcurl.
maybe you have a different linux distribution / operating system on your machine?

@bmorgan could be that there are ways to mitigate this, e.g., double quotes or removal of additional whitespace characters in the respective script file? ruby on rails - curl : (1) Protocol https not supported or disabled in libcurl - Stack Overflow

I’m on ubuntu 20.04

$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 20.04.2 LTS
Release:	20.04
Codename:	focal

I have the following packages for SSL, curl and wget and it looks like they all came as dependencies for others I installed

$ sudo apt list --installed | egrep -i "ssl|curl|wget"

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

libcurl3-gnutls/focal-updates,focal-security,now 7.68.0-1ubuntu2.5 amd64 [installed,automatic]
libcurl4/focal-updates,focal-security,now 7.68.0-1ubuntu2.5 amd64 [installed,automatic]
libio-socket-ssl-perl/focal,focal,now 2.067-1 all [installed,automatic]
libnet-smtp-ssl-perl/focal,focal,now 1.04-1 all [installed,automatic]
libnet-ssleay-perl/focal,now 1.88-2ubuntu1 amd64 [installed,automatic]
libssl-dev/focal-updates,now 1.1.1f-1ubuntu2.4 amd64 [installed,automatic]
libssl1.1/focal-updates,now 1.1.1f-1ubuntu2.4 amd64 [installed,automatic]
openssl/focal-updates,now 1.1.1f-1ubuntu2.4 amd64 [installed,automatic]
perl-openssl-defaults/focal,now 4 amd64 [installed,automatic]
ssl-cert/focal,focal,now 1.0.39 all [installed,automatic]
wget/focal,now 1.20.3-1ubuntu1 amd64 [installed,automatic]

The other possibility is that the cmake in use has been downloaded from the Kitware site as the binary bundle. IIRC, these bundles that Kitware ship don’t enable SSL in libcurl due to export restrictions on encryption software, so I would double check on how cmake was installed here first.

Otherwise, I would suspect a glitch either in the internet connection, or the server.

In this way, cmake is installed.

tar -zxvf cmake-3.14.0-rc2.tar.gz
cd cmake-3.14.0-rc2
sudo make install

can you please tell how can i do that manually ?
Thanks in advance!

okay. let her try with this.

download the datasets you need (or simply all of them if you don’t care ;-)), and extract them in a suitable location, e.g., /path/to/geant4.10.7-install/share/Geant4-10.7.2/data

cd to the location, tar -xzf dataset.tar.gz

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.