Error while loading shared libraries libG4geomUSolids.so

Hello,
I obtain the following error in a modified example:

./exampleB1: error while loading shared libraries: libG4geomUSolids.so: cannot open shared object file: No such file or directory

This thread suggests compiling the usolids library and provides a link Tests required when -DGEANT4_USE_USOLIDS="ALL" is enabled for Geant4. · Issue #11 · christopherpoole/CADMesh · GitHub. However, the link is defunct. Where can I find libG4geomUSolids to add to my lib64 folder?

1 Like

This library is no longer in Geant4 - note that the link refers to Geant4 10.3, which is very old and no longer supported. I’d strongly suggest updating to use the latest version 11.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.