Error with precompiled library for OSX Monterey

I’ve recently upgraded my macbook to Monterey (with clang 13) and decided to try the precompiled library available on the Geant4 download page. I downloaded it, untarred it, and sourced the file in the bin/ directory.

Now, when running cmake within my existing model, I see an error:

CMake Error in AES/CMakeLists.txt:
  Imported target "Geant4::G4RayTracer" includes non-existent path


in its INTERFACE_INCLUDE_DIRECTORIES.  Possible reasons include:

 * The path was deleted, renamed, or moved to another location.

* An install or uninstall procedure did not complete successfully.

* The installation package was faulty and references files it does not

I don’t have interest in G4RayTracer and am not using it in this application. Additinally, while I do have some packages installed via homebrew, but they don’t get installed to /opt/homebrew

I then tried to run cmake within the B4 example directory and saw the same error. Is there an indication that the pre-compiled OSX library isn’t a clean install?

My experience is that you have some package which was last built before you upgraded. Somewhere in either CMakeCache.txt, or in one of the CMake files that Geant4 generates for itself.

You’re right. The issue was that my path included the bin/ directory an older install of geant4. When I thought I was sourcing from this precompiled binary, I was actually picking up a different

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.