Example B1 erorr: can't find Qt53Dcore.dll etc

I built geant4.10.7.2 and example B1 on Windows 10 with Qt enabled. When running the example, I get 3 pop up windows regarding Qt53Dcore.dll, Qt53Dextras.dll and Qt53dRender.dll.

2021-09-30 08_54_30-2021-09-30 08_46_25-exampleB1.exe - System Error.jpg ‎- Photos

Windows 10
Visual Studio 19.28
cmake 3.19.2

This is strange, since during the cmake process, it looks like Qt libraries were found. And I don’t see errors for Qt5 dlls other than the “3D” ones.

from CMakeCache.txt

//Build Geant4 with Qt support

//The directory containing a CMake configuration file for Qt53DCore.

//The directory containing a CMake configuration file for Qt53DExtras.

//The directory containing a CMake configuration file for Qt53DInput.

//The directory containing a CMake configuration file for Qt53DLogic.

//The directory containing a CMake configuration file for Qt53DRender.

//The directory containing a CMake configuration file for Qt5Core.

//The directory containing a CMake configuration file for Qt5Gamepad.

//The directory containing a CMake configuration file for Qt5Gui.

//The directory containing a CMake configuration file for Qt5Network.

//The directory containing a CMake configuration file for Qt5OpenGL.

//The directory containing a CMake configuration file for Qt5PrintSupport.

//The directory containing a CMake configuration file for Qt5Widgets.

And I can see both the Qt5 cmake files and dll’s in question:

Directory of C:\Qt\5.15.2\msvc2019_64\bin

11/06/2020 05:32 AM 406,000 Qt53DAnimation.dll
11/06/2020 05:32 AM 1,486,320 Qt53DAnimationd.dll
11/06/2020 05:32 AM 414,704 Qt53DCore.dll
11/06/2020 05:32 AM 1,188,848 Qt53DCored.dll
11/06/2020 05:32 AM 666,096 Qt53DExtras.dll
11/06/2020 05:32 AM 1,657,840 Qt53DExtrasd.dll
11/06/2020 05:32 AM 354,800 Qt53DInput.dll
11/06/2020 05:32 AM 1,389,552 Qt53DInputd.dll
11/06/2020 05:32 AM 51,184 Qt53DLogic.dll
11/06/2020 05:32 AM 191,472 Qt53DLogicd.dll
11/06/2020 05:32 AM 167,920 Qt53DQuick.dll
11/06/2020 05:32 AM 59,376 Qt53DQuickAnimation.dll
11/06/2020 05:32 AM 227,824 Qt53DQuickAnimationd.dll
11/06/2020 05:32 AM 474,096 Qt53DQuickd.dll
11/06/2020 05:32 AM 78,320 Qt53DQuickExtras.dll
11/06/2020 05:32 AM 243,696 Qt53DQuickExtrasd.dll
11/06/2020 05:32 AM 55,792 Qt53DQuickInput.dll
11/06/2020 05:32 AM 201,712 Qt53DQuickInputd.dll
11/06/2020 05:32 AM 161,776 Qt53DQuickRender.dll
11/06/2020 05:32 AM 576,496 Qt53DQuickRenderd.dll
11/06/2020 05:32 AM 87,536 Qt53DQuickScene2D.dll
11/06/2020 05:32 AM 359,408 Qt53DQuickScene2Dd.dll
11/06/2020 05:32 AM 2,239,472 Qt53DRender.dll
11/06/2020 05:32 AM 7,005,680 Qt53DRenderd.dll

Directory of C:\Qt\5.15.2\msvc2019_64\lib\cmake

09/23/2021 05:22 PM Qt53DAnimation
09/23/2021 05:22 PM Qt53DCore
09/23/2021 05:22 PM Qt53DExtras
09/23/2021 05:22 PM Qt53DInput
09/23/2021 05:22 PM Qt53DLogic
09/23/2021 05:22 PM Qt53DQuick
09/23/2021 05:22 PM Qt53DQuickAnimation
09/23/2021 05:22 PM Qt53DQuickExtras
09/23/2021 05:22 PM Qt53DQuickInput
09/23/2021 05:22 PM Qt53DQuickRender
09/23/2021 05:22 PM Qt53DQuickScene2D
09/23/2021 05:22 PM Qt53DRender

I don’t get any errors during build or install (RelWithDebInfo). I do get one warning:

C:\Geant4\geant4_10_07\source\visualization\OpenGL\src\G4OpenGLQtViewer.cc(606,77): warning C4305: ‘argument’: truncation from ‘int’ to ‘bool’ [C:\Geant4\geant4.10.7.2-build\source\G4OpenGL.vcxproj]

Then when I build example B1 (also RelWithDebInfo) I don’t get any errors or warnings. I have tried with and without manually putting Qt path in make file. Though it doesn’t seem necessary since again it seems to find the Qt make files.


Yet when I run example B1, I get the popup errors. If I run exampleB1.exe run1.mac, I get 2 popups. If I run without “run1.mac”, so expecting visualization, I get 3 (including Qt53Dcore.dll).

Any ideas?


CMakeCacheGeant build.txt (25.9 KB)

CMakeCache B1-build.txt (16.2 KB)

install output.txt (383.7 KB)

Compile output.txt (100.9 KB)

Is the directory C:\Qt\5.15.2\msvc2019_64\bin in the PATH environment variable for the session where you’re running exampleB1? That’s needed to ensure they’re found by the application at runtime.

1 Like

Thank you! I thought I had added that directory to PATH, but had not. I just added it and still got a couple different errors. But that was because my Geant4.10.7.2-install/bin path was listed after my Geant4.10.7-install path in the list, so it was looking in the wrong place. (I had just patched 10.7.0 to 10.7.2 and took the opportunity to add Qt support).

Thanks again.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.