G4Elastic on CRY / G4

Hello everyone , I would like to know if someone can help me . I installed Geant4 and the library CRY (cosmic ray shower library ) on ubuntu , but when I try to compile its Geant4 example , it gives me errors, in particular it is an error of ‘‘G4Elastic.hh’’ that doesn’t exist . Does someone know what is the problem and if this library can really be ‘‘binded’’ to G4?

If this is an example provided with the CRY software, then the issue should be reported to them.

Hi. Few years ago when i have to use CRY with geant4 (also in ubuntu) i had to add these lines in .bashrc file:
##needed to use CRY
export G4INSTALL=/usr/local/geant4.10.05.p01
export G4SYSTEM=Linux-g++
export G4WORKDIR=$HOME/geant4_workdir
source /usr/local/cry_v1.7/setup

Hope it helps.
Carlos

1 Like

Thank you so much , I’ll try this suggest .

Hi Carlos, I tried your suggestion, but the terminal gives me the same problem, it seems like there are different libraries.hh in geant4 and cry. Do you maybe know what is the problem? What version of Geant4 you used few years ago when you link it to cry?

Hi. I was using geant4.10.04 or later. If you can compile and install i will bet on environmental variables or the need for adjustments in the cmake/makefiles.
Can you post the error?

1 Like

Thank you so much for your reply. When I tipe ‘make’ in the geant example directory of CRY_v1.7 , the error is this :


Thank you so much .

Dear fm1812, i think that, has bmorgan said, is related to CRY.
I was googling a bit and as far as i understood G4LElastic was replaced some years ago by G4HadronElastic. It can be seen in geant4.10.0 release notes, in the examples modifications:
“exrdmPhysicsList: use standard constructors for EM physics, removed local low-energy EM physics. Use standard constructors for hadronic builders instead of obsolete. Replaced G4LElastic and G4LCapture with G4HadronElastic and G4NeutronRadCapture.”

I am afraid that, in order to run that example you have to change it accordingly or use an old geant4 version recomended by CRY.

Cheers:
Carlos

1 Like

Ok thank you so much , I’ll try to fix this thing and ask to CRY forum despite I think it is not existing. Thank you so much for your reply .