Geant4 10.6 on CentOS 7 not able to install

Dear All,
I have been trying to install Geant4 10.6 on CentOS 7 for a couple of days and I don’t know what else to try. I will try to describe everything I have tried.
I installed CentOS 7 (Core) the GNOME Desktop. After this all the problems started since the “Development Tools” group doesn’t meet the requirements of gcc 4.9.3 or higher. Because of this, I have installed the devtoolset-8 in the following way.

    yum update -y
    yum -y install centos-release-scl
    yum install devtoolset-8
    scl enable devtoolset-8 bash

I installed cmake 3.12.3 as follows:

tar zxvf cmake-3.*
cd cmake-3.*
make -j4
make install

After this, I downloaded geant4.10.06.tar.gz, did the untar, created the geant4.10.6-build folder and tried the following configuration.


I need this specific configuration to run Allpix2 software later. After that, I got quite a few issues with missing libraries and I had to install the following:

yum install xerces-c xerces-c-devel
yum install qt5-qtbase-devel
yum install expat
yum install expat-devel
yum install libXmu-devel
yum install motif
yum install openmotif-devel

After all this (which implied a painful online search) the configuration worked. However, after the configuration, the directory geant4.10.06-install is not created and I also got the following error

CMake Error at /home/work/Documents/Geant4/geant4.10.06-build/Externals/G4ENSDFSTATE-2.2/src/G4ENSDFSTATE-stamp/download-G4ENSDFSTATE.cmake:159 (message):
Each download failed!

error: downloading '' failed
     status_code: 1
     status_string: "Unsupported protocol"
     --- LOG BEGIN ---
     Protocol "https" not supported or disabled in libcurl

Closing connection -1

I guess I am doing quite a few wrong things but at the same time, I was wondering why the process is so painful. To summarize, I need help to go through the installation process.

Thanks in advance,

The “Unsupported protocol” error is due, IIRC, to cmake being built with its builtin version of libcurl, which doesn’t support SSL. I can’t recall the invocation to use the system libcurl, but running CMake’s bootstrap --help should list this.

Thanks for the reply. In the end, I dropped it and decided to install 10.05.