Geant4 Failing to Match with Measurement of Ca/Ti on neutron-induced capture gamma characteristic peaks

Hello everyone,

I use the Geant4_10.6.3 and choose the Physical List “Shielding.hh”. I use the neutron data libraries, ENDF-VII.1, In order to be consistent with Measurements.

Our goal is to obtain elemental concentrations based on a tool with pulsed neutron source. The inelastic or radiative capture interactions between neutrons and nuclei in the formation emits characteristic gamma rays, and the elemental composition of the formation is calculated based on the intensity of characteristic gamma rays. Common elements in the formation include Si, Ca, C, O, Mg, etc. The first step of our work is to obtain the standard spectrum of a single element. We found that Geant4 simulation results of most elements are in good agreement with the measurements, except for a few elements showing large differences in characteristic peaks, such as the capture spectra of Ca and Ti, as shown below. The capture spectrum of Ca shows no obvious characteristic peaks, such as 1.94264 MeV(100), 6.4207 MeV(49.1525). The highest capture characteristic peak (1.381745MeV) of Ti is not shown in Geant4.

Thanks in advance for your help!
Best regards,
Yi Ge

Hi, the first thing I suggest is to switch version to geant4 11.0 patch03. In addition, I would suggest to try also the physics list with ParticleAllHP.

Thank you for your reply. I’ll try as you suggest. :grinning:


What energy neutrons are you using for your primary beam? The ENDF plots are for thermal capture gamma rays. If you are using say, 14 MeV neutrons, there are many other channels open that can change or cover up that spectrum.

Here, a run of example Hadr03.
The physics constructor is G4HadronPhysicsShielding() (see

lydia.mac.txt (366 Bytes)
lydia.out.txt (1.5 KB)


Thank you for your reply. Yes, the primary particles is 14 MeV neutrons. But i track the each neutron-induced gamma from the radiative capture using the the process name of “nCapture”. So I think I’ve directly got the net capture gamma spectrum.


Thank you for your reply and result. From the result, I see that you have used the latest version of Geant4 11.0, and the peak of 1.38 MeV of Ti can be clearly observed in the figure, but the characteristic peak between 6 MeV and 7 MeV can not be seen clearly. So is it because the new version fixes the use of the cross section library? I would like to try to get the capture energy spectrum of Ca in the new version to see if I can get the same characteristic peaks as the cross section library.

Sorry for the delay. Here, Ca40

lydia.mac.txt (336 Bytes)

Hi Maire,
Thank you again. I will try to use the new version of Geant4 and check the physics list.

Hi Lydia,
I have similar questions to yours, I was wondering whether there are similar results to the database after using the 4 11.0?

Hi Lydia,
I am trying to get neutron capture peaks of elements in the cement including Si, Ca, etc., using 2.45 MeV neutron. I was using geant4.10.7 and didn’t get the 6.42 MeV peak of Ca. After reading this post, I run with the latest version of geant4 and got the same result.
I also tried “SetUseOnlyPhotoEvaporation(true)”. It turns out that a ~6.3 MeV peak appears, but the 3.5 MeV peak of Si disappears.
The physicslists i have tried are “QGSP_BIC_HP”, “Shielding.hh”, “ShieldingLEND.hh”.
I would like to discuss this problem and find a solution. Best wishes.

Hi WangXiaohu,
After using Geant4 11.0.3, I was able to obtain some correct capture characteristic peaks.

Hi Maire,
Because of the computer system, I finally installed the latest version of Geant4 successfully recently, and finally saw the capture characteristic peak of Ca, thank you again. But there are still two questions, 1. First, around 3MeV should not be the characteristic peak of Ca. 2. Secondly, when I defined the neutron energy in the macro file, the characteristic peak around 6.4 disappeared when the unit was “14.1 MeV”, as shown in the following figure and macro file. And I inactivate neutronInelastic, hadElastic and nFission.

/gun/energy 14.1 MeV
/process/inactivate hadElastic
/process/inactivate neutronInelastic
/process/inactivate nFission

Ca.mac.txt (478 Bytes)

Hi Chen,
I try to switch the material Si in example hadr03 and the result is same as you. I can not see the 3.5 and 4.9 MeV peak of Si. I am sorry I also have no idea about this.

Hi Chen,
To add some information, I used a neutron source of 14MeV, and only collected the capture of Si through the Physics Process (nCapture), which has the peak of 3.5MeV.

The difference comes from USE_ONLY_PHOTONEVAPORATION
I do not know which one is, eventually, more correct.
No doubt that a Geant4 expert will tell us …

chen.mac.txt (356 Bytes)