I am sourcing:

source /cvmfs/

on lxplus9. However this breaks the python3 setup:

[mrettig@lxplus900 ~]$ python3
Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Python path configuration:
  PYTHONHOME = (not set)
  PYTHONPATH = (not set)
  program name = 'python3'
  isolated = 0
  environment = 1
  user site = 1
  import site = 1
  sys._base_executable = '/usr/bin/python3'
  sys.base_prefix = '/build/jenkins/workspace/lcg_release_pipeline/install/Python/3.9.12/x86_64-centos9-gcc11-opt'
  sys.base_exec_prefix = '/build/jenkins/workspace/lcg_release_pipeline/install/Python/3.9.12/x86_64-centos9-gcc11-opt'
  sys.platlibdir = 'lib'
  sys.executable = '/usr/bin/python3'
  sys.prefix = '/build/jenkins/workspace/lcg_release_pipeline/install/Python/3.9.12/x86_64-centos9-gcc11-opt'
  sys.exec_prefix = '/build/jenkins/workspace/lcg_release_pipeline/install/Python/3.9.12/x86_64-centos9-gcc11-opt'
  sys.path = [
Fatal Python error: init_fs_encoding: failed to get the Python codec of the filesystem encoding
Python runtime state: core initialized
ModuleNotFoundError: No module named 'encodings'

Current thread 0x00007ff84dbddf00 (most recent call first):
<no Python frame>

Is this the right place to get support for this ? Many thanks !

Hey Markus,

Just to clarify, I didn’t handle these builds, but I’m aware that the installations are based on the “geant4” external packages. When I checked the environment variables after running “”, I noticed they were set up using /cvmfs/, and it seems Python3 is included there.

To set the environment for this, I executed the following, and it resolved the Python issue for me:

source /cvmfs/ 

Alternatively, you can use Geant4 from the LCG release:

source /cvmfs/ 

But this one is the MT build of Geant4.

Thank you.

The first link works for me.

However, the second:
find: File system loop detected; ‘/cvmfs/’ is part of the same file system loop as ‘/cvmfs/’.

The second option also works, just disregard this message.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.