Geant4 Installation problem on Linux Ubuntu

Hi, I am a new user trying to install geant4 using ubuntu16.04.6 i686 and cmake 15.0.
below is the error screenshot.

When i set EXPAT=OFF, then again facing the another error, not found suitable qt version and some related to cmake, i am new please guide, how to solve this problem, I also tried CentOS7 on virtual box and faced the same error.

Thank you for your help


For QT try doing below on your terminal:

sudo apt-get install libqt5opengl5-dev
sudo apt-get install libqt4-dev

and also just be sure on a new OS I generally do:

sudo apt-get install cmake libx11-dev xorg-dev libglu1-mesa-dev freeglut3-dev libglew1.5 libglew1.5-dev libglu1-mesa libglu1-mesa-dev libgl1-mesa-glx libgl1-mesa-dev

This should solve your issue!


Good Luck!


Thank you @sanchitsharma very much i was suffering this problem form almost a week ago and now you solved. it build successfully.
One more thing when i run make -j 2 command to install then it give again again error of gean4 data libraries, screenshots are given below.

thank you for your help


Good to know that your issue got resolved. This current issue must be due to a bad internet connection or its unavailability. As a test do -DGEANT4_INSTALL_DATA=OFF and proceed. Download and set up data manually later on.


1 Like

Thank you It works now.