Getting error with gps while using gears in windows 10

_Geant4 Version:_11.2.0
_Operating System:_Windows 10
Compiler/Version: Visual Studio 2022
CMake Version: 3.28.1

I’ve started doing some simulations on Geant4 (the basic stuff) and tried to add a General Particle Source (GPS) to my simulation and Gears doesn’t seem to accept this macro. There’s another macro called gun that has essentially the same functionalities but not all. For example, I wanted my source to be isotropic and for that the corresponding line of code is /gps/direction iso but when I tried doing that with gun it didn’t recognize the iso part.

Thanks in advance for any clarification about this issue.

As I understand, the gps macro should be defined within gears and I saw the guy doing the tutorial using the gps macro without any issues. I’m a bit lost in figuring out a way to tell gears to consider the .hh file for the gps rather the one considered for gun.

@Jing_Liu may be able to answer in detail, but maybe also worth raising an issue on the gears GitHub project.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.