GRAS 4.0 as external application to Geant4

Hello experts,

I’ve been using GRAS as an external application to Geant4 until the (GRAS) version 3.4. After the release of version 4.0 I haven’t been able anymore to use it as external application, although I’m able to call the executable in batch mode. I’ve been performing always the same process:

  1. Change G4RunManager to GRASRunManager;
  2. source gras with bin/gras-env.sh.

Just to be sure I wasn’t doing anything wrong, I tried to run the examples inside GRAS for external applications. Unfortunately I get the exact the same error as in my own application:

[ 20%] Building CXX object CMakeFiles/app_exe.dir/exampleN01.cc.o
/home/lghizoni/Geant4/gras-04-00/examples/gras_in_external_application/N01_with_GRAS/exampleN01.cc:38:10: fatal error: GRASRunManager.hh: No such file or directory
#include “GRASRunManager.hh”
^~~~~~~~~~~~~~~~~~~
My only guess would be that I’m sourcing the wrong GRAS file?

I would be thankful for any help :slight_smile:

BR,
/Leonardo.