Hadr02 core dumb error while using different physics lists

_Geant4 Version:_11.1.1
_Operating System:_Linux_Ubuntu-22.04
_Compiler/Version:_11.4.0
_CMake Version:_3.22.1


I have two problems regarding my simulation:

  1. The first problem is regarding the Hadr02 example where I included source files and header files to include more physics lists these files are PhysicsList.cc, PhysiceListMessenger.cc, PhysicsList.hh, and PhysiceListMessenger.hh. The code ran fine after this, but when I tried to run a macro file using “QBBC” physics list (./Hadr02 macro.in), I encountered this error:
    ‘’’
    -------- EEEE ------- G4Exception-START -------- EEEE -------
    *** G4Exception : had001
    issued by : G4NeutronGeneralProcess::PreparePhysicsTable(…)
    Incomplete configuration of the neutron general process.
    Neutron elastic process is not defined

*** Fatal Exception *** core dump ***
**** Track information is not available at this moment
**** Step information is not available at this moment

-------- EEEE -------- G4Exception-END --------- EEEE -------

*** G4Exception: Aborting execution ***
Aborted (core dumped)
‘’’
2. The second problem is, in this same process, I tried to run the macro file again but this time I was using the “Shielding” physics list. This time it worked, the whole process was finished
but the output root file was empty, there were empty histograms.
So what do I do?