How do i run geant4 on ssh? What souces use?

I have been trying to follow the tutorial at the link Geant4 Usage at CERN | EP-SFT in order to be able to simulate geant4 runs at the ssh given by cvmfs. The problem is that it does not work.

I am not able to use the command cmake. even though i have followed the instruction at the site correctly.

Do you know what souces should i use to make it run?
In particularlly, source /cvmfs/ works well, the problem is that when i run the executable ./build, it gives the same problem as here Available UI session types: [ Qt, tcsh, csh ] Invalid MIT-MAGIC-COOKIE-1 keyqt.qpa.xcb: could not connect to display :0 qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found - #18 by bmorgan

As that page is referring to very old versions of Linux and GCC, it should be considered out-of-date. The /cvmfs/ should work fine as is the latest LCG release, though it comes with Geant4 10.7.2 only.

For the MIT-MAGIC-Cookie issue, have you tried the suggestions linked in this post?

I think i should have been more specific, sorry. The error message is this one:

Available UI session types: [ Qt, Xm, GAG, tcsh, csh ]
qt.qpa.xcb: could not connect to display 
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, webgl, xcb.

It seems a problem with the QT plataform, but i am not sure why, since i already have the environment variables done.

This also usually indicates an issue with the local or remote X configuration or Qt install. Whilst I realise it’s not completely helpful, I’d suggest plugging Could not load the Qt platform plugin "xcb" into Google - that comes up with a lot of posts on Qt-related and StackOverflow forums. As the solution may well be specific to your system, the tests/solutions in those posts should help to diagnose exactly where the problem lies.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.