How to Download Qt in GEANT4 for TOPAS GUI

_Geant4 Version:_PACKAGE_VERSION “10.4.2”
_Operating System:_CentOS LINUX
Compiler/Version: CPack ,Terminal
CMake Version: CPack

how to download Qt visualization ? so that TOPAS can show GUI .
So by using the code Ts/UseQt = “True” , TOPAS will not show any error .

Thank you

As TOPAS is an external application, this is best asked to its developers/support.

1 Like

Okay I will do that .

Actually the error according to the TOPAS was -

"Error : Attempt to the run in Qt mode when TOPAS was build against a GEANT4 with no Qt.

Rebuild against a version of GEANT4 that has Qt or change Ts/UseQt to False."

So, I thought it might be any fault from my side while downloading the GEANT4 , in which Qt mode was not downloaded .

My question is can’t we Download Qt again ? If possible can you suggest procedure to do the same .

Thank You

Enabling/disabling Qt is part of the build of Geant4 so an existing install can’t be updated easily (unless you still have the build directory for that install). If TOPAS is relying on a pre-existing install of Geant4 (i.e. it does not come with a set of Geant4 libraries), then all you would need to do is do a new build/install Geant4 enabling Qt support and point TOPAS as that. The instructions for that are in the Installation Guide, see the GEANT4_USE_QT cmake option.

As a TOPAS developer as well as a Geant4 developer, I do know that TOPAS comes as a package that includes Qt. No need to install either Geant4 or Qt. In fact, if you have installations of Geant4 or Qt on your system, keep TOPAS way from them. That might be the source of your troubles.

So, have another look at the TOPAS Installation Guide. You must have missed something.

Okay I’ll check this.
If you can tell how to to keep TOPAS away from GEANT4 .Because as you said I have installed both GEANT4 and TOPAS .
I have installed TOPAS, Tool for Particle Simulation Version 3.1.p3 .

Thank You

Okay thank you
I will go through the Installation guide .

Actually when I am trying to run the TOPAS examples it shows the result in View A and the exact problem is that it does not open in GUI .
Hence can you suggest any solution to this .

Thank You

I don’t know whether TOPAS uses shared of static libraries for Geant4, but if shared, then do you have the path to your local install of Geant4 in the environment variable LD_LIBRARY_PATH? If so, that may be confusing TOPAS. Check the value of that environment variable to see if that’s the case. You can also try running

$ ldd <path/to/TOPAS/program>

which should print which libraries, such as Geant4, it is actually picking up.

Yes this is what it is showing ,after the opening TOPAS in terminal to run the TOPAS input file

Welcome to TOPAS, Tool for Particle Simulation (Version 3.1.p3)
Loading parameters starting from: 225Ra_production.txt

Geant4 version Name: geant4-10-03-patch-01 [MT] (24-February-2017)
<< in Multi-threaded mode >>
Copyright : Geant4 Collaboration
Reference : NIM A 506 (2003), 250-303
WWW : Geant4

TOPAS is in MT mode, setting number of threads to: 8

I think Qt is confusing in TOPAS and hence quiting some of the programms of TOPAS .

I am unable to join the TOPAS forum though I have filled the registration form past 3 weeks .

Thank you

Tool for Particle Simulation Version 3.1.p3 .

Hello can you help me in running the TOPAS example file
I am trying to run the scoring file specifically the Origincount.txt file .But it is showing error that is

Error in the scoring setup ,
"TOPAS exiting due to a serious error in scoring setup
sc/MyScorer/Quantity has unknown value: OriginCount . "

can you tell why it is saying unknown value ,is it because of the version of TOPAS ,do I need to update it ?
Thank You

Please address this to the TOPAS Forum.

I have no idea why i am not able to join the TOPAS forum though I have filled the registration form past 3 weeks .

Please contact

1 Like

Thank You @bmorgan and @allison .
Now I am able to run my TOPAS programms without any GEANT4 related issues .

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.