How to scale down one of the cylinders?


Using the basic example B4a I changed a lot of the geometry (and some other things) in detector construction to match what I’m trying to achieve (8 cylinders). I built all of them but somehow the one I want to place first in the center of the world (0, 0, 0) looks bigger than normal even when I change the hz value or use different coordinates. Even when it’s the only cylinder I’m viewing using OpenGL on OS X (no X11, I’m using XQuartz) it’s still bigger than the rest of them (which comparing the values should be way more compact). I’ll attach a few screenshots for reference.
This is the geometry for the faulty cylinder:

 G4double irsus = 0.*mm;
 G4double orsus = 29.96*mm;
 G4double hzsus = 0.87*mm;
 G4double startunghisus = 0.*deg;
 G4double spanningunghisus = 360.*deg;

G4Tubs* calorimetersus
= new G4Tubs(“Calorimetersus”,

auto calorLV_sus
= new G4LogicalVolume(
calorimetersus, // its solid
Mat_pmma, // its material
“Calorimetersus”); // its name

new G4PVPlacement(
0, // no rotation
G4ThreeVector(0, 0, 0), // at (0,0,0)
calorLV_sus, // its logical volume
“Calorimetersus”, // its name
worldLV, // its mother volume
false, // no boolean operation
0, // copy number
fCheckOverlaps); // checking overlaps

Legend: green - the cylinder I want to scale down somehow,
white - the biggest cylinder,
blue - smaller cylinder.
I want the green cylinder to look like its true size.

This is the close-up: (keep in mind the ending of the green cylinder is the same as the start of the white cylinder). I don’t understand why there’s such a big gap between the two of them (green and white)

This is what it looks like from a distance, you can’t even see the blue one anymore since it’s so close to the white one (0.45mm).

The green cylinder shouldn’t be that large, its height is almost the same as the distance between the white one and the blue one which from the first screenshot you can tell it’s really small.

How can I fix this? It’s still loose even when it’s the only cylinder on display, it can’t possibly be the values since I’ve tried changing them and I get the same result, a loose cylinder. I rewrote the code a bunch of times, changed the name of the values and it still looks the same. I don’t know what I’m doing wrong :sob:

Could it be a problem caused by the viewer? Or am I doing something wrong? I don’t get any errors when compiling the code.

I hope you can understand my problem, it’s hard to explain it when I don’t know what’s wrong with my code.

Thank you!

It’s difficult to figure out where is the problem without seeing the full code. Please attach to your message.

PS. The division of radiuses irsus and orsus by 2 looks strange. Are you sure this is what you want?