Installed Octave. G4 borked

_Geant4 Version: 11.0.0
_Operating System:_Sonoma 14.3
_Compiler/Version: X code 15.3
_CMake Version:_3.29.2

Hi all,

I’ve been running G4 successfully on this machine for several months but have just installed Octave after which my G4 compiles fail with the following and rather alarming errors (fie attached). Clearly the issue is with QT.

Any suggested fixes? Can I roll-back to the previous QT version? Need I reinstall G4? Or are there switches in CMake I can change?

Regards

Tim
G4_QT_Compile_Errors.txt (19.7 KB)

OK, no worries bmorgan saved the day with his posting here: Errors while building geant4 with qt5 - #5 by Richard_Foster