Internal e- conversion

Dear Geant4 users,

I am using TOPAS tool based on Geant4. When simulating a radioactive decay the following table is printed:

====== Radioactive Decay Physics Parameters =======

Max life time 1.4427e+06 ps
Internal e- conversion flag 1
Stored internal conversion coefficients 1
Enable correlated gamma emission 0
Max 2J for sampling of angular correlations 10
Atomic de-excitation enabled 1
Auger electron emission enabled 1
Auger cascade enabled 1
Check EM cuts disabled for atomic de-excitation 1
Use Bearden atomic level energies 0

Does anyone know how to set the internal e- conversion flag to 0? For example, it’s possible to disable the Auger electron emission in the UI by command /process/em/auger false. Is there anything similar to this in case if internal conversion?


I think you ask on TOPAS platform. By the way in the physics list you can implement;

G4RadioactiveDecay* RadioactiveDecay = new G4RadioacQveDecay;
RadioactiveDecay-­‐>SetICM(false); // Internal e- conversion


Dear Mikhail, I think the best is to contact TOPAS developers.

Dear drvijayraj,

thank you!


Dear guatelli,

thank you for the feedback.


before initialization :
/process/had/deex/setIC false