Issue with Geant4-v10.00.p02 Data Files

_Geant4 Version:_10.00.p02
_Operating System:_CentOS-7
_Compiler/Version:_gcc 12.1.0


I am trying to install Geant4-v10.00.p02, but am getting an the following error when running exampleB1:
-------- EEEE ------- G4Exception-START -------- EEEE -------
*** G4Exception : PART70000
issued by : G4NuclideTable
G4ENSDFSTATEDATA environment variable must be set
*** Fatal Exception *** core dump ***
-------- EEEE -------- G4Exception-END --------- EEEE -------

I believe that this is related to the downloading of the associated data files when building the project.

By default, cmake is configured to download the data files from “”; however, this URL no longer seems to exist. I was able to find the new URL for the data files (“”), so I instead pointed cmake to download the files from this source. When building the project, these files are successfully downloaded and copied to my install directory, except for G4ENSDFSTATE1.0/.

I have tried manually copying over this directory and setting the correct environmental variable, but this leads to a separate error that seems to be related to an incorrect formatting of one of the data files. This leads me to believe that my approach causes an incorrect version of the data files to be downloaded, leading to the exception when running the example.

Can someone provide me with the proper way to retrieve these data files given their new location? Thanks in advance for any suggestions.

Look in the release notes to find the correct version of the data files. Manually downloading them and setting the environment variable is expected to work (and may be necessary with such an old Geant4 version). If you still get errors, post again.

1 Like

This is reported as Bugzilla 2535, and a fix is in progress. For now, follow @dsawkey’s advice to get the correct files.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.