Lowering the step-size in the magnetic field in example field04

I have tried to run example field04. I would like to decrease the step size in the magnetic field for higher accuracy of results. I used the following commands in the interactive visualization (all the parameters are 10 times smaller than that in the example):

/vis/scene/add/axes -10 10 0 3 mm
/field/setMinStep 0.001 mm
/field/setDeltaOneStep 0.001 mm
/field/setDeltaIntersection 0.01 mm
/field/setDeltaChord 0.3 mm
/field/setEpsMin 2.5e-8 mm
/field/setEpsMax 0.005 mm
/run/beamOn 10

However, no amount of stepping parameters that I change has any effect on the step-size. i.e. the distance between the yellow points did not change in the following picture

If anyone could guide me how to lower the step-size, I would be very thankful.

Did you select the “smooth trajectories” option for visualization?

/vis/scene/add/trajectories smooth

This will collect additional points along the curved trajectory found in the B field and draw it more accurately. The actual tracking and stepping takes the field fully into account.

Thanks for your help.

You mean, actually, all these smaller parameters have worked in the simulation? And, these yellow points does not all the smulation steps, these yellow points just some (a part of) of the steps? Do I understande correctly?

Then I used the command “/vis/scene/add/trajectories smooth”, but the distance between the yellow points did not change.

Are the yellow points the normal steps (i.e., the G4Step points)? The text in your image is unreadable – if the things hidden in the dark blue are important, perhaps you could copy-paste the actual text into a post?