Missing header in application

Hello Geanters

I installed Geant4-10.06 apparently correctly (no errors, no warnings). The latest installation, I used:

cmake -DCMAKE_INSTALL_PREFIX=/home/<user>/Builds/geant4.10.06-install ../../Sources/geant4.10.06/ -DGEANT4_INSTALL_DATA=ON

then make, and make install

very simple options to test it.

Then, I compiled my application (after sourced geant4.sh) and i got this error:

/home/<user>/Analysis/TDIS/g4sbs/src/G4SBSPhysicsList.cc:18:33: fatal error: G4DataQuestionaire.hh: No such file or directory #include "G4DataQuestionaire.hh"

The first time I installed Geant4 with more options, I just copied the file G4DataQuestionaire.hh in the include folder and in principle the application compiles, but since I got more issues trying to open the interactive window (not able yet), I tried to install Geant4 as I indicated with the same error.

Any suggestion of why this is happening.

I am using, Centos 7, cmake 3.8.2, gcc 4.9.2

Thank you


The G4DataQuestionaire.hh interface was removed in the 10.6, as described in the release notes:


The class was header-only and only used internally by packaged physics lists to check dataset environment variables. These are checked anyway by processes that require them, so it should be possible to remove it from your application without an issue.

1 Like