I work in multithreading mode. In this mode many events are not running absolutely. I mean there are many empty events without primary particle and any kind of interactions. Also the final results are in strong contradiction with results obtained, when I install GEANT with MULTITHREADING=OFF option. I can make a screenshot of empty events if it’s necessary. What is the problem ?

Dear S_Amirkhanyan,

MT Option is just run same events with dividing total event number to number of threads. If your program running in one thread, it also should run in mt mode. But,

  • If you’re running MT under windows, it is not recommended.
  • If you’re getting your output with Root toolkit, its not completely compatible for threads.

I recommend you to check the code.

Hi All
How can it configure Geant4 for MT after installation? Is it possible? How?
Or is the only way to reinstall Geant4?

Thanks in advance,

If you compiled source without MT option, you can’t. If you compiled with MT option, you can use “runManager->SetNumberOfThreads(…)” function.

Thank you.
No, it is a machine that I am using.
I checked it and now I am sure, they have installed Geant4 without MT.

I found how we can check MT is on or off and where is that data:
Just go to install_dir/geant4.10.06/bin/ directory then open geant4-config file.

You will see this line (L: 86-87)

# - multithreading

interested for this topic