NE213_Neutron detector

Hi, I have emailed the code to ‘daslee’ and ‘surajsinghdeos’. I hope it is of use to you both.


Hello Sir, I was looking for proper scintillator simulation example especially the NE213 and I saw this discussion. I would really appreciate if you send me also that code of yours (
Thank you

Hello, Sir. I try to simulate the pulse shape of scintillator detectors. I am wondering how you record the optical photons that reach the PMT cathode. Do you check the boundary process status(e.g. Detection or Absorption)? I don’t know if it is sufficient to just record the photons get into the sensitive volume without checking its boundary status. I would be very appreciate if you will share your example files. My email is Thank you.

I do not use a sensitive detector at the photocathode in my code. I merely count photons that reach the PMT entrance window. I never intended to model the PMT dynamics; but merely to account for photon transport out of the scintillator, so this was sufficient for my purposes.

I have been receiving many requests for this code through the forum and outside it. Rather than emailing it repeatedly, I will try to set up a link to Google Drive to allow people to access it. I will post the link here when I have done so.

The code can be downloaded as a tarred gzipped file at the below link:

1 Like

I am trying to run code in Geant 4 10.11 and I am getting the following error. Can you please help how can I run it?
Thank You
/usr/bin/ld: CMakeFiles/OpNovice.dir/src/ in function OpNoviceDetectorConstruction::Construct()': undefined reference to G4OpticalParameters::SetScintEnhancedTimeConstants(bool)’
collect2: error: ld returned 1 exit status
make[2]: *** [CMakeFiles/OpNovice.dir/build.make:251: OpNovice] Error 1
make[1]: *** [CMakeFiles/Makefile2:76: CMakeFiles/OpNovice.dir/all] Error 2
make: *** [Makefile:130: all] Error 2

just started using Geant4 - would it be possible to share the file again?

Many thanks

The code was written for Geant4 10.7.2 in which one had the option to not use the enhanced time constants. This is no longer an option in Geant4 11.0. So just comment out the line:


A version that works on Geant4 11.0.2 is here:

1 Like

thanks for the prompt answer and sharing the example

Thank You Sir for sharing the updated code as well as the solution.