Open Inventor unable to generate pictures

Hi all,

So recently, I was able to build and install SoXt which has allowed me access to use Open Inventor for Geant4. However, when I tried to run the basic example B1 using the Open Inventor visualization, I got a blank screen (attached image) and my terminal output printed out the following error:

QColor::setRgbF: RGB parameters out of range

Could not create shader of type 2.

Warning: "" failed to compile!

and when I tried to execute the command /vis/open OIXE, the entire example crashed and closed.

I’m not sure what the cause of the problem is and any help would be appreciated! I may try reinstalling Coin3D and SoXt to see if that resolves the issue, but if there is a fix that would be awesome.


Hi Jason

I happen to know Fred Jones, who responded to you at length earlier, is on vacation at the moment so let me see what help I can give you.

The messages you quote come from Qt. You might have more luck building without Qt. Could you try that?


Hi John,

Yup that was the fix! Thanks so much for your help and Fred’s, you’ve really saved me a lot of trouble. Just out of curiosity, since I built Geant4 without Qt support, I no longer have access to using the QT supported OGL viewer. Is there any benefit to using Open Inventor over the QT supported OpenGL viewers?

Again, thanks so much for your help!


OK. Great.

The OI and Qt viewers are similar in many ways - both have interactive control of the view, for example. It’s a while since I used the OI viewer (I had build problems) but it has some nice features such as clicking to make mother volumes invisible so you can see what’s inside. I’d be interested to hear you assessment of it. The Qt viewer has a nice help window and and interactive scene tree.

I guess when loaded together they compete for graphics resources - hence the crash. I don’t know any way around that.


Okay that sounds very interesting. I’ll definitely have to see which one works better for me then. Thanks for your help!