Photons absorbed but not reemitted in liquid Argon


I’m working on my first simulation in Geant4, which is the production of electrons via the photoelectric effect in liquid argon. I am struggling to get the low energy photons (gamma), in the range of 11-15 eV, to travel through the liquid argon. It seems like they are immediately absorbed and not re-emitted, as I expected they would be. Convinced there was something wrong with my code, I looked at the example TestEm5 that comes with Geant4 and found that, at least with the default settings, the same thing happens: if I choose the particle to be gamma and the absorber material to be G4_lAr, the photons are immediately absorbed and not emitted again.

I think if I can understand the situation in TestEm5 I can translate it to my own project. Can someone please explain? Thanks!


(PS, I apologize if this is not the exact correct category, I wasn’t sure which was best)

11-15 eV photons are at the very low end of the energies which Geant4 typically supports. You may be running into standard energy loss processes which may be overestimating the absorption. You may also want to look into the “production cuts” which are set as part of the physics list, and perhaps set the gamma cut to zero.

Dear Maxwell,

do you probably want to investigate the scintillation (emission of optical photons) in liquid argon? If it is the case you should look at the examples included in the folder examples/extended/optical (OpNovice, OpNovice2, LXe).

In few words, you have to characterize the properties of the material in DetectorConstruction and activate the physics library for the emission of optical photons in the main program with:

#include “FTFP_BERT.hh”
#include “G4OpticalPhysics.hh”
#include “G4EmStandardPhysics_option4.hh”

Best regards,


Hi All,

I tried adjusting production cuts referencing page 204 in the manual for application developers. I didn’t see any improvement after trying to set the lower limit to 10 eV and setting the default run cut to be very low (0.001 nm). @mkelsey, does it seem likely that this could just be outside the capability of Geant4? Is there maybe some way I could limit the photons to only interacting in the photoelectric effect on the target, so I could disregard this part of the simulation?

To answer your question @Gabriele_Birindelli, I’m primarily interested in studying the photoelectrons produced when these gamma make it to their target (an Aluminum disc), not the scintillation. However, since this all takes place in a volume of liquid Argon, the photons have to make it there first, which is the part I’m struggling with. I thought that the process by which the photons would get there would be simple excitation and deexcitation.

Thank you both,

There’s no general way to enable/disable physics processes based on a G4Region. In Different physics list per G4Region?, it’s discussed how do this for EmDNAPhysics, but that is a special case. It is possible to enable/disable some of the EM within-process features (like PIXE or fluorescence) by region, but not whole processes.

Do you think it would be possible for me to initially produce the photoelectrons without the liquid argon, save that data somehow, and then run another simulation with liquid argon in which the electrons are produced by a particle source at the time, position, etc. that they would be produced if they’d been hit by the photons? I haven’t learned any kind of data collection or output with Geant4 yet so that would be new to me, but if that seems viable I can work on it.

Yes. We do that sort of “rethrowing” in my experiment’s simulation. Geant4 does not provide that functionality directly. You’d need to have, for example, a stepping action to capture the generated secondaries, and write them out to a file. Then you’d need a primary action to read that file back in, and use the info of the secondaries to create primary particles and primary vertices (actually, you could use G4ParticleGun for that, passing in the kinematics).

Thank you very much, that seems like a great way for me to proceed with this. You’ve been a huge help :slight_smile: