Post installation problem: data files

I’m really new to data structures and such and so a little bit lost. I followed the installation guide and so far the main installation seemed to have worked. I got three directories


Additionally I tried the command

cmake -DGEANT_INSTALL_DATA=ON /path/to/geant4.10.03.p03-install/share/Geant4-10.3.3

and because I didn’t know which one was right I also tried:

cmake -DGEANT_INSTALL_DATA=ON /path/to/geant4.10.03.p03

To my understanding this should install the data files (which you can also download manually). But I am not quiete sure how to understand what is happening.

In my geant4.10.03.p03-install directory I can’t find any directory named data as I have seen in other examples.

When I try to setup the environment variables via

source /path/to/geant4.10.03.p03-install/bin/

I get a bunch of error messages looking like this:

-bash: cd: /path/to/geant4.10.03.p03-install/bin/../share/Geant4-10.3.3/data/G4NDL4.5: No such file or directory

Similiar when I try to run one of the examples (e.g. B1) I get the following error:

Available UI session types: [ GAG, tcsh, csh ]

-------- EEEE ------- G4Exception-START -------- EEEE ------- *** G4Exception : PART70001 issued by : G4NuclideTable ENSDFSTATE.dat is not found. *** Fatal Exception *** core dump *** -------- EEEE -------- G4Exception-END --------- EEEE -------

*** G4Exception: Aborting execution *** Abort trap: 6

Would appreciate some help on how to fix these problems. Thank you!

anyone who could help? please…

cmake remembers certain settings so your install may be in a strange state. Might be simplest to clear out everything in gean4-build and geant4-10.03.p03-install and start again.

When you are in geant4-build run

cmake -DGEANT4_INSTALL_DATA=ON -DCMAKE_INSTALL_PREFIX=/path/to/geant4.10.03.p03-install /path/to/geant4.10.03.p.03

This should configure to download the required data files and install things into the -install directory.
Now build and install to actually do it

make -j4 && make install

You should now be able to

source /path/to/geant4.10.03.p03-install/bin/

and run the examples.

Also, just noticed that in the original post, you use -DGEANT_INSTALL_DATA, but the cmake option is -DGEANT4_INSTALL_DATA.

The automatically downloaded data goes into CMAKE_INSTALL_PREFIX/share/Geant4-10.x.x/data.
If it is there, you should check whether system variables are set. For example, looking at your exception, makes sense to check G4NEUTRONHPDATA system variable. Type echo $G4NEUTRONHPDATA in teminal (other variables for other data files can be found in Geant4 setup guide ‘postinstall’ chapter).

thanks very much! I could setup the data files with your help. Everything seems to be installed correctly now. But now there is a new problem. When I try to run an example it gives me different errors about missing viewers. For example:

ERROR: No current sceneHandler. Please create one.

ERROR: G4VisCommandSceneAddScale::SetNewValue: no viewer.
Auto direction needs a viewer.

ERROR: G4VisCommandSceneAddLogo::SetNewValue: no viewer.

ERROR: G4VisCommandsViewerSet::SetNewValue: no current viewer.

/vis/viewer/set/hiddenMarker true

ERROR: G4VisCommandsViewerSet::SetNewValue: no current viewer.

/vis/viewer/set/viewpointThetaPhi 120 150

ERROR: G4VisCommandsViewerSet::SetNewValue: no current viewer.

Do i need to enable the option



And others maybe?

Update: I had to enable this option and it worked. That said, I had to clear everything, enable the option and then install geant4 again. It doesn’t seem to work afterwards, that is if you already have installed geant4. Same as for the data=on option.