Problem in building

Hello, a researcher gave me this G4 app to modify it…I tried first to compile it but I get error both on my computer (windows machine) and by using cvfmfs.

This is the error on cvmfs

and here the log CMakeOutput - cvfms.txt (83.0 KB)

This is the error on my computer

and here the log
CMakeOutput-windows.txt (9.7 KB)

I guess it’s a a Cmake problem…maybe it’s written using an old G4 version…is there a way to solve it?
Thank you

Ok…I see the problem is the missing HepMC library, then I downloaded it here HepMC / HepMC3 and I’m tryinh to install it on my computer following the instructions on that page, but I get error during the installation
This is the full log on the terminal

log.txt (3.6 KB)

and here the C:/Program Files/HepMC3-3.2.3-build/CMakeFiles/CMakeError.log". and C:/Program Files/HepMC3-3.2.3-build/CMakeFiles/CMakeOutput.log

CMakeError.txt (3.1 KB)

CMakeOutput.txt (19.3 KB)

@bmorgan, maybe you know how to solve it…

The log is telling you what the error is:

-- Could NOT find Python (missing: Python_EXECUTABLE Python_LIBRARIES Python_INCLUDE_DIRS Interpreter Development.Module) (Required is at least version "2")
CMake Error at python/CMakeLists.txt:282 (if):
  if given arguments:

    "Python_INCLUDE_DIRS" "AND" "Python_EXECUTABLE" "AND" "(" "(" "STREQUAL" "2" "AND" "X" "STREQUAL" "X" ")" "OR" "." "STREQUAL" "2.X" ")"

  Unknown arguments specified
Call Stack (most recent call first):
  python/CMakeLists.txt:522 (bindings)

-- Configuring incomplete, errors occurred!

It needs Python, but it’s not installed, or can’t be found, on the system.

Thank you @bmorgan but I’ve Python on my computer
as you can see in this print screen

and it’s strange that HepMC can’t find it, because I use ROOT and ROOT needs python too! (I mean, when I installed ROOT I had to install python first )…

is there a way to set manually the path of python for HepMC installation?
Thank you

Please see the HepMC3 project page for all of its build options: HepMC / HepMC3

Thank you @bmorgan but these are instructions that I was following…

but when I run the command

cmake -DHEPMC3_ENABLE_ROOTIO=OFF -DCMAKE_INSTALL_PREFIX=../hepmc3-install ../HepMC3-3.2.3

I get the error showed in my previous message (the error regarding of python, even if I have python)…

Given that HepMC can’t find the python path, is there a way to set the path?