Problem with

Hi everyone.
I get the following error when running projects:

$ cmake -DGeant4_DIR=/home/name/geant4-v11.2.1-install/lib/Geant4-11.2.1 ../B1
$ make
[100%] Built target exampleB1
$ ./exampleB1
./exampleB1: error while loading shared libraries: cannot open shared object file: No such file or directory

The ldd command showed the following:

$ ldd ./exampleB1 | grep -i qt 
/ => not found 
/ => /lib/x86_64-linux-gnu/ (0x00007f44d0770000)
/ => /lib/x86_64-linux-gnu/ (0x00007f44cff90000)
/ => /lib/x86_64-linux-gnu/ (0x00007f44cf990000)
/ => not found
/ => not found
/ => not found
/ => not found
/ => not found
/ => not found

But this file is on the system:

$ find /lib/ -name

I installed everything:

$ sudo apt-get install g++ cmake cmake-curses-gui build-essential expat libx11-dev libxmu-dev libexpat1 libexpat1-dev libqt4-dev libglu1-mesa-dev freeglut3-dev mesa-common-dev
$ sudo apt-get install qt5-default qtbase5-dev libqt5quickcontrols2-5 libqt5multimedia5 libqt5webengine5 libqt5quick5 libqt5qml5 qtchooser qt5-qmake qtbase5-dev-tools

The solution with the “$ source /home/name/geant4-v11.2.1-install/bin/” does not help.
I also tried to re-build Geant4 after installing all the libraries with the conditions below, but the problem remains.


I’m using windows 10 with wsl, where:
Geant4 Version: 11.2.1
Operating System: Ubuntu 20.04.6 LTS (on version 22.04.3 the situation is the same)
CMake Version: 3.16.3

Tell me, please, how can I solve this problem?

It’s probably this bug in WSL/Qt: ELF section .note.ABI-tag breaks shared libraries · Issue #3023 · microsoft/WSL · GitHub

See that and related for workarounds.

Thanks for your reply.

I stole the command from your link

$ sudo strip --remove-section=.note.ABI-tag /usr/lib/x86_64-linux-gnu/ 

And got an error with “……”. I fixed it with the command

$ source /home/name/geant4-v11.2.1-install/bin/

After that it showed problems with “Available UI session types: [Qt, tcsh, csh], qt.qpa.xcb: …, qt.qpa.plugin: …”.
Then I got tired of it. I left WSL and just installed Virtual Box with Ubuntu 20. In this implementation, everything worked from the first installation.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.