Problem with PTL and CMAKE_PREFIX_PATH

Ubuntu 22.04
GCC 11.4.0
cmake version 3.29.0

So I was trying to run my first project on Geant4 but I keep getting this error

CMake Error at /home/linuxbrew/.linuxbrew/Cellar/cmake/3.29.0/share/cmake/Modules/CMakeFindDependencyMacro.cmake:76 (find_package):
Could not find a package configuration file provided by “PTL” with any of
the following names:


Add the installation prefix of “PTL” to CMAKE_PREFIX_PATH or set “PTL_DIR”
to a directory containing one of the above files. If “PTL” provides a
separate development package or SDK, be sure it has been installed.
Call Stack (most recent call first):
/home/lakshya/geant4/geant4-install/Geant4Config.cmake:286 (find_dependency)
CMakeLists.txt:5 (find_package)

– Configuring incomplete, errors occurred!

Yes I realise the problem has something to do with mentioning the path of PTLConfig.cmake file but I am a beginner to cmake and geant4 which is why I used spack to download all dependencies as mentioned by the geant4 user manual

If someone can help me out how to set the installation prefix of PLTConfig.cmake in the CMAKE_PREFIx_PATH it would be of a great help

Could you outline exactly how you installed the dependencies please? It seems you’re using a CMake from linuxbrew, but then using spack. It looks like you built/installed Geant4 yourself, so what build settings did you use?